AnsweredAssumed Answered

PHP 5.3.0 errors (deprecated messages)

Question asked by BradleySlavik on Jun 3, 2011
Latest reply on Aug 16, 2011 by BradleySlavik

Title

PHP 5.3.0 errors (deprecated messages)

Your post

When is FileMaker going to release updated PHP files for FileMaker support that will work with PHP 5.3.0 and later? This is not a new version of PHP. I hate to operate with files that I had to edit by hand. Especially since your support documents indicate that 5.3.0 is required on the Macintosh, I should not have to turn off warnings and other deprecated messages to use your libraries.

Here is the information from your document fms11_cwp_php_en.pdf
Note FileMaker Server has been tested with PHP version 5.2.11, for Windows and for Mac OS X v10.5, and with PHP version 5.3.0, for Mac OS X v10.6. For best results, use the appropriate version of PHP.

I installed the FileMaker.php and Filemaker directories from /Library/FileMaker Server/Web Publishing/FM_API_for_PHP_Standalone.zip

Outcomes