0 Replies Latest reply on May 27, 2010 9:27 PM by fmdataweb

    PHP API Issue with Radio Buttons/Valuelist

    fmdataweb

      Title

      PHP API Issue with Radio Buttons/Valuelist

      Your post

      I'm using FileMaker Pro 11 and FileMaker Server 11 and all is working well. Server is FileMaker Server Advanced v11 on Mac OS X 10.6.3

       

      I have a database with a valuelist with the following values:

      Sim
      Não

      [this is yes and no in Portuguese]. I'm displaying this valueist as a radio button on an input form, however there is a problem with the Não which appears in the web browser as "NNão" (i.e. there is an extra N at the beginning). The php page is saved as Unicode UTF 8 and other static text on the page also has "Não" which appears correctly. If I view the html source the radio button code appears as:

      Code:
      <input type="radio" name="Question1" value="Sim" validate = "required:true " class = "radioClick">Sim
      <input type="radio" name="Question1" value="NNão" validate = "required:true " class = "radioClick">NNão


      The php code for the input field is:

      Code:
      <?php
       foreach($yesnos as $yesno) {
      $selected "";
      if( $yesno == $record->getField('Question1') ){
      $selected " checked=\"checked\"";
      }
      $yesno htmlspecialchars($yesno);
      ?>

      <input type="radio" name="Question1" value="<?php echo $yesno?>"<?php echo $selected?> validate = "required:true " class = "radioClick"><?php echo $yesno?>
      <?php
      }
      ?>


      I've run out of troubleshooting ideas at this point and would appreciate any insights anyone out there can offer.

      Many thanks,
      Steve