4 Replies Latest reply on Mar 9, 2012 11:11 AM by woodstock_1

    PHP Custom Web Publishing running, but not found?

    bangsjaman

      Title

      PHP Custom Web Publishing running, but not found?

      Your post

      Hi, 

       

      I have installed Filemaker Server correctly and PHP is working. But PHP can not contact the web publishing server.I have tried from my own PHP files, which I know is working.I have tried from PHP site assistant, and it cant connect "Publishing engine is not running on the specified server".I have tried from the Filemaker Server Test page: http://192.168.0.3/fmi-test/phptest.php?lang=en&server=ADSERVER1 The PHP connection to the FMServer_Sample database failed.


      Notice: Undefined index: message.error.fm.22 in C:\Program Files (x86)\FileMaker\FileMaker Server\Web Publishing\web-server-support\test\fmi-test\phptest.php on line 36
      The PHP test was not able to communicate with the Web Publishing Engine. Make sure you have PHP publishing enabled and the database has the fmphp extended privilege enabled. (Error 22; Unknown error)

       

      I have reinstalled Filemaker Server several times. I have redeployed Filemaker Server with and without PHP and IIS configuration.I have tried unchecking the the PHP support and reenabling it again.PHP extended priveligies is enabled in the relevant files. I have also tried with the sample file, where PHP is also enabled. Still not working.I have even tried reinstallating IIS and installing PHP manuel, but ends up with same result.IIS and PHP is working fine, but they cant connect to Filemaker Web Publishing.No firewall or antivirus is running on the server. Windows firewall is disabled.


      Any ideas?


        • 1. Re: PHP Custom Web Publishing running, but not found?
          littledog
            

          Hi,

          Interesting situation.

          As I can see  - you are on Windows platform.

          Anyway - what do you mean - reinstalling FM Server? Using "Remove server" only or Remove and then delete all associate FM files? After Remove there still are FM server folders left.

          What PHP you are using? From FM Server or existing on your computer?

          How you get files up to FM server - via upload or copy to folder? Upload must be used.

          Open file shown in error message and look what's wrong.

           

          Wrong Test show that there something is wrong with webserver or PHP. 

          • 2. Re: PHP Custom Web Publishing running, but not found?
            bangsjaman
              

            Thanks for the suggestions. You are right Windows 2008 server 64 bit.

             

            I tried the reinstall again, as you suggested. Uninstalled Filemaker Server, rebooted server, deleted Filemaker Folder. Rebooted. Installed Filemaker Server again. Uploaded the database this time....but same result.

            This time I even tried before applying the server update.

             

            But this time I noticed something little different. Because now I get HTTP error 503 when trying to access any webpage. So now PHP and IIS is not working at all.

            I also noticed that the application pools in IIS stops running after trying to access any webpage. I can start them again and they keep running untill I access any page again.

            I have turned on the 32-bit app pooling in IIS, so that should not be the problem.

             

            Same problem as FMSA10 FileMaker Server Advanced 10 and SBS (Small Business Server) 2008 - HTTP Error 503

             

            But I cant make that solution work?

            • 3. Re: PHP Custom Web Publishing running, but not found?
              bangsjaman
                

              I now found a solution. Not quite sure what it was, but after what I tried in the previous post, I saw that IIS ISAPI filters seemed disabled or not installed. I removed IIS again. Rebooted. Installed IIS again, made sure that CGI, ISAPI Extenstions and ISAPI filters where installed as well. Then from Filemaker Server Admin, I redeployed the PHP Webserver and then it suddenly worked..

               

              Any way, thanks for your help.

              • 4. Re: PHP Custom Web Publishing running, but not found?
                woodstock_1

                I also had this same issue with Windows 2008 R2 Enterprise 64 bit (also vmware) and FileMaker Server 11.0.3.309 install. After I enabled 32-Bit Applications in the Application pool it still didn't work, I reinstalled FileMaker Server that fixed it!

                Not exactly sure either what the cause of this was either.. I confirmed that PHP was working even though FileMaker PHP connector wasn't so the issue wasn't with php itself.