1 2 Previous Next 19 Replies Latest reply on Aug 27, 2009 1:00 PM by TSGal

    Schedule error while running on FMp 10 server

    pat_pai

      Title

      Schedule error while running on FMp 10 server

      Your post

      Good morning,

       

      I've just installed FMp10 server on a previouslly running FMP 9 machine and all is well except for when i run my schedules to see it they all work.

       

      I have 5 daily schedules for backups, and one i run them right now, it says "Permission denied" in the status beside that schedule.

       

      And this is what i get as an emial notification:

      FMPPROD10 Schedule "Tuesday" aborted; the destination "filewin:/E:/weekbackup/Tue/" is not writable

       

      Is this something new in FMP10, anyone know what i should check/fix?

       

      Thank you very much

        • 1. Re: Schedule error while running on FMp 10 server
          philmodjunk
            

          What OS does your Server machine use?

           

          The error message is consistent with trying to write to a folder that doesn't have write permission enabled. Check that.

           

          Also check the path name in your schedule set up for the backup folder. The absence of a \ in the wrong spot can also trigger this error message even though the path is shown as "valid" when you check it. (This is a known bug with FMS 10). Check it against the path examples given in the documentation.

          • 2. Re: Schedule error while running on FMp 10 server
            pat_pai
              

            Im using windows server 2003 standard edition.

             

            It's funny because this is an upgrade from 9 to 10 and everything was already working fine when i was in 9.

             

            I will check documentation for path systax altho i was using the one that works on my FMp 9 production server.

             

             

            • 3. Re: Schedule error while running on FMp 10 server
              pat_pai
                

              syntax is ok, i've given full rights to all users on that folder and subfolders and files and i still get a weird error message about that folder not having write privs.

               

              why did they go and change this, it was just working fine before... :)

              also i also get this error message:

              FMPDEV10 Backup aborted. Invalid backup destination: "filewin:/E:/weekbackup/test_2009-08-17_1337/F:/CFS/ADMO Clients.fp7".

               

              I see the stampdate folder being created but whats the rest of this for with the F:/ ... part?

              Im a lost for words here, don't know why this creation of folder was added.

               

              Does anyone know what user on the server is used to accomplish this?

               

               

              • 4. Re: Schedule error while running on FMp 10 server
                philmodjunk
                  

                Check your schedule's destination and source file paths. This is exactly the error you get when you're missing a \, that's why the log runs the two references together into a single, invalid file path.

                 

                I had to log on to one of my servers to check this more carefully. Look for a missing backslash between the the drive letter and the top level folder name. That's where FM server will accept the absence of a slash as "valid" even though it is not.

                • 5. Re: Schedule error while running on FMp 10 server
                  pat_pai
                    

                  Ok phil thank you very much.

                  It seams that adding "//" right after the Drive letter is helping for now altho the jobs are hung right now.

                  I will monitor that more.

                   

                  Quick question, do i only need to modify my schedule task location with those double "//" or the paths as well in the database Folder section of the admin screen?

                   

                  Like should i also add them to my source destination or only when a top level folder exists?

                   

                  this is what i got for source right now: filewin:/F:/

                   

                  +++UPDATE++

                   

                  thx Phil for the tip on double "//".

                  Turns out i need them everywhere a path is psecified, if you don't it will hang the schedule.

                   

                  Just tested it now and i was able to use the new backup feature.

                   

                  Thx a million :)

                  • 6. Re: Schedule error while running on FMp 10 server
                    pat_pai
                      

                    Hi phil,

                     

                    Another problem aroze.

                    Not that my schedules are working it seams im geting another bug/error, i put my source folder to: filewin:/F://

                     

                    works fine for schedules but now when i look at my database list under administration, it doesnt show anything.

                     

                    I tried removing the // from source but i might need a restart because it still doesnt show the list but my schedules now hang. This is just ridiculous, do you have that problem?

                     

                    Thx again

                    • 7. Re: Schedule error while running on FMp 10 server
                      philmodjunk
                        

                      That's very strange. I wasn't describing a double backslash. Just the bug where:

                       

                      filewin:/D:Folder Name/

                       

                      is accepted as valid when it should be:

                       

                      filewin:/D:/Folder Name/

                      • 8. Re: Schedule error while running on FMp 10 server
                        pat_pai
                          

                        I will use my test machine now to make sence of it all, will post bck tomorow when i get more of it tested.

                        I was on DEV today and i cant keep restarting that server :)

                         

                        Thx

                        • 9. Re: Schedule error while running on FMp 10 server
                          pat_pai
                            

                          Here is my exact setup for my TEST box:

                           

                          OS: Windows Server 2003 standard edition

                          Server version: FMP 10.0.1.64

                           

                          DB folder path: filewin:/E:/

                          Backup path: filewin:/C:/BackupFMP10/

                           

                          My schedule backup folder path is set to:  filewin:/C:/backupFMP10/

                           

                          And right now, im only trying to backup 1 file.

                           

                          When the schedule is Ran it does the following in the scheduler window:

                          Sets STATUS column to: "Permission denied"

                           

                          And sends me 2 email notifications in the following order:

                          1.

                          2009-08-18 08:11:27.025 -0400 Error 494 FMPTEST10 Backup aborted. Invalid backup destination: "filewin:/C:/backupFMP10/test_2009-08-18_0811/E:/LIN_DESS/LIN_DESS.fp7".

                           

                          2.

                           

                          2009-08-18 08:11:27.025 -0400 Warning 156 FMPTEST10 Schedule "test" aborted; the destination "filewin:/C:/backupFMP10/" is not writable.

                           

                          Altho i get these messages, i can see that the Date Stamp folder is at least created. But nothing else happens.

                           

                          As you can see my paths are written properlly and if i run this under FMP 9 server, NO problems at all.

                          Yesterday i was having same issues and my FMp10 DEV server was patched to most recent patch: 10.0.2.206

                           

                          I really need to understand what is going on here.

                           

                          Im stuck between 2 versions right now and i cant do anything well in either one of them.

                           

                          FMP 9 works fine with schedules but as that JAVA updater >7 problem.

                          With FMP10 the JAVA >7 problem is gone, but im stuck with a non-functionning scheduler for backups.

                           

                          Thank you for all your hel again :)

                          • 10. Re: Schedule error while running on FMp 10 server
                            pat_pai
                              

                            Should i be sending this directly to FileMaker?

                            Do i need to open a support ticket with them and if so, where do i go for that?

                             

                            I need to know if the above problem i've got with FMP10 server is fixable or if i need to take a decision weither to keep 10 or revert back to 9.

                             

                            thank you very much again :)

                            • 11. Re: Schedule error while running on FMp 10 server
                              TSGal

                              patpai:

                               

                              Thank you for your posts.

                               

                              Your error message says that directory is not writable, so please make sure the directory has permissions set to read/write for all users.  If this still doesn't fix the problem, then it may be easier to talk directly with a Support Technician who can try a number of things with you on the phone rather than piecemeal here.

                               

                              TSGal

                              FileMaker, Inc. 

                              • 12. Re: Schedule error while running on FMp 10 server
                                pat_pai
                                  

                                Ok i found where the BUG eminates from now.

                                My privs are correct the problem comes from within the FileMaker software.

                                 

                                It seams that the new Scheduled backup features don't work well compared to FMP 9 server.

                                 

                                The problem resides within the Database configuration tabs.

                                When you set in the "Default Folders" tab a source destination where your databases are stored, there's a small nuance between 9 vs 10.

                                 

                                Hee it is:

                                In 9 i can set the database folder path to this: filewin:/E:/ (E is local to the machine here and it's basically just a partition of the HD)

                                 

                                And this works in 9 i have no issues with the Scheduler. 

                                 

                                 

                                In 10 however, if you set the database folder to this: filewin:/E:/

                                It will give me all the errors i've reported above in another answer to this thread.

                                 

                                When i change the database folder path in FMP10 to a specific folder path like this for example: filewin:/E:/LIN_DESS/

                                and run the scheduler, it will succeed in taking a copy of a database file within that folder and copying it over to the backup Stampdate folder.

                                 

                                 

                                So can we have someone look at this and comfirm this.

                                 

                                Right now i've got a potential work around to fix this, but i would like to avoid it if possible.

                                 

                                • 13. Re: Schedule error while running on FMp 10 server
                                  TSGal

                                  patpai:

                                   

                                  Thank you for the information.  Unfortunately, I cannot duplicate the problem.  This is what I have done:

                                   

                                  1. FileMaker Server 10 is running on Windows Server 2003.

                                   

                                  2. I created a schedule with the following parameters:

                                   

                                  Schedule type: Backup

                                  Schedule name: TSGal

                                  Databases to back-up: file:FMServer_Sample.fp7

                                  Backup folder: filewin:/D:/

                                  Maximum backups to keep: 1

                                  Verify backup integrity: Disabled

                                  Frequency: Once Only

                                  Start date: 8/21/2009 11:00 AM

                                  End date: none

                                  Repeat: none

                                  Email notifications: Disabled

                                  Email addresses: N/A

                                   

                                  3. I performed the action "Run a Schedule now".

                                   

                                  4. The file was backed up successfully.

                                   

                                  I only have an internal C: and D: drive.

                                   

                                  Make sure you have read and write privileges to the root level of the E: drive.

                                   

                                  Please let me know what else I can try to duplicate the problem.

                                   

                                  TSGal

                                  FileMaker, Inc. 

                                  • 14. Re: Schedule error while running on FMp 10 server
                                    pat_pai
                                      

                                    Check the following just to be on the safe side. Everything else looks ok to me.

                                     

                                    In Database Server ->Default Folders, enable "Additional database folder" under 'Database folders' and make sure its set to your D: drive like this: filewin:/D:/

                                     

                                    Once you do that, you will need do the following:

                                    Create a folder on your D: drive like SampleDB and copy in it a copy of the sample DB. 

                                     

                                    You will need to stop and restart server for the new location to take effect.

                                    Once your restart, the 'databases' list should show the new file structure + DB(s).

                                     

                                    After that, you should be rdy to try your schedule. 

                                     

                                    Thx for trying to replicate this :)

                                     

                                    1 2 Previous Next