AnsweredAssumed Answered

Server 14 and Application 14 on PC and Email Scripts are not working

Question asked by evansj2 on May 21, 2015
Latest reply on May 21, 2015 by disabled_ntaylor

Title

Server 14 and Application 14 on PC and Email Scripts are not working

Your post

All

we updated our server to 14 and im using the Rev 14 application and now the scripts for email are not working. Example

Simple button with the script assigned to it (under options Pause current script is selected).

Perform Script [ “status change script” ]

Send Mail [ Send via E-mail Client ; To: "avtechs@rpi.edu;mediaops@rpi.edu"; Subject: "Trouble Ticket Status: " & Issues Tracking::
Status & ", Ticket ID#: " & Issues Tracking::Issue ID & ", Reported Problem Type: " &Issues Tracking::Problem Type; Message: Issues
Tracking::Assigned Technician &
" has updated the ETR listed below¶¶" &
"ID Number: "& Issues Tracking::Issue ID& "¶"&
"Title: "& Issues Tracking::Title & "¶¶"&
"Type of Problem: " & Issues Tracking::Problem Type & "¶¶"&
"Building: " & Issues Tracking::Building & "¶"&
"Room: " & Issues Tracking::Room& "¶"&
"Date and Time of Event: " &Issues Tracking::Date of Event & "," & Issues Tracking::Time of Event & "¶¶"&
"Description:¶" & Issues Tracking::Description & "¶¶"&
"----------------------------------------------------------------------------------------" &"¶"&
"The status of your reported issue has changed.¶"&
"Technical Comments: ¶ "
&Issues Tracking::Technician_Comments &"¶¶2--¶"
&Issues Tracking::Technician_Comments[2] &"¶¶3--¶"
&Issues Tracking::Technician_Comments[3] &"¶¶ 4--¶"
&Issues Tracking::Technician_Comments[4] &"¶ 5--¶"
&Issues Tracking::Technician_Comments[5] &"¶¶"
&"----------------------------------------------------------------------------------------" &"¶"&
"Be Kind- Rewind¶" ]

 

FYI- this is the "status change script"
Set Error Capture [ On ]
Allow User Abort [ Off ]
#If Resolution Field is Empty set Status field to Open.
If [ IsEmpty ( Issues Tracking::Resolution ) + IsEmpty ( Issues Tracking::Date_Closed ) + IsEmpty ( Issues Tracking::
Time_Closed ) ]
Set Field [ Issues Tracking::Status ; "Open" ]
#If Resolution Field is NOT Empty set Status field to Closed.
Else
Set Field [ Issues Tracking::Status ; "Closed" ]
Set Field [ Issues Tracking::Date Expected Return ; "" ]
End If

 

None of this is all that complex. When you press the button either nothing happens or you get the following

"There was an error addressing the email. Please check that your email software is installed correctly."

I use Outlook for email and it all works fine.

When i open the same file in 13.0.5.503 it opens but i get the error from the email bug (see my other posts)

Certainly seems like there is a major bug in Rev 14 :-(

5-21-2015-8-45-12-AM.gif

Outcomes