1 Reply Latest reply on Jun 28, 2013 10:11 AM by bashir1102

    Server problem?

    SteveKeiser

      Title

      Server problem?

      Your post

           I have a table occurrence that I made so I could show only active records. When I display the layout it works fine when the database is running off my hard disk. When I run the database off the server, it doesn't work right. Instead of the found records displaying only the active records, it displays the total number of inactive+active records. It shows a line in the list view for every record, but only the active records show any information on the line.

            

           Here is my setup:

           Table------------Table2

           Table:TableID = Table2:TableID AND Table:cInactive = Table2:Inactive    where cInactive is a calculation field that always returns the active value of the Inactive field.

           The layout uses the "Table" table, but each of the fields on the layout are from the "Table2" table occurrence.

           This setup works when the database is local on my hard drive, but does not work from FileMaker Server.

           Is there some server setting that will correct this problem?

        • 1. Re: Server problem?
          bashir1102

               Hi,

               That kind of logic is not going to work reliably unless your are specifically using something like the GoToRelatedRecord script to navigate from Table 1 to Table 2. Instead it would be far more reliable to just show your main table instance and then use scripts to enter find mode, set your critera (in this case active records) and then display the results.

               While the method your using can be used for alot of things such as filter criteria in value lists, calculations (sometimes) etc, its really not optimal or reliable for filtering records on a layout.

                

               Hope that helps....