10 Replies Latest reply on Dec 3, 2013 2:15 AM by BasBoss

    Server Script Error 100

    hickam

      Title

      Server Script Error 100

      Your post

      I am trying to use Filemaker Server 10 to import records from one file to another. According to the Server compatibility in the script maker importing (no dialog) is compatible. However, it doesn't work. I have checked and double checked log ins, I have tried numerous ways of copying the information across and have reduced the errors presented in the Event log viewer to a single error; 100. (File is missing) It appears that a server script will not see another file but only the one the script is in. It will not even see the second file when a sub script is run that opens the file (no I am not using the open file script step (which is incompatible) but a script that simply "shows all" in the second file.) I can find no documentation on this issue in the knowledge base, pdf files, etc. I would think that filemaker would design such a feature because to me it would be a common maintenance script ran from the server so I wonder if I am missing something.

        • 1. Re: Server Script Error 100
          mrvodka
             Are you trying to import a filemaker file? If so this wont work. Server side import/export has to be very specific. It has to be from a specific directory and can not use fmnet protocol or fp7 files.
          • 2. Re: Server Script Error 100
            philmodjunk
              

            A lot of us have griped about this. See Knowledge Base Article #7035 for more on the limitations you'll encounter with this.

             

            The work around is to set up an OS scheduled robot file that performs the script. Since it excutes as a client, you don't encounter the server side script limitations.

            • 3. Re: Server Script Error 100
              ICT-Pro
                

              Hi,

              Copy the source file;

              C:\program files\Filemaker\Filemaker Server\Data\Documnets\ (depend on your installation location)

               

              and than try, hopefully it will work.

               

              Cheers

               

              Z.Ahamd 

               

               

              • 4. Re: Server Script Error 100
                slemson
                  

                I'm getting the same error but I'm not importing.  I too am not using any incompatible script steps.  The only "trickiness" about mine is that the script goes to a layout that contains an external data source (a Filemaker database hosted on a different server).  Essentially I go to this layout to see if there are any records on our external server that are approved to copy into our internal system.  If so, I set the 5 fields' contents into variables, switch to the layout with our internal system, create a new record and set the field contents to the variable contents.

                 

                Am I breaking some undocumented rule here by trying to access a table that resides on a different server?

                • 5. Re: Server Script Error 100
                  mrvodka
                    

                  Yes unfortunately, the server side script does not recognize the fmnet protocol. Here is a thread with more info about it.

                   

                  http://forum-en.filemaker.com/fm/board/message?board.id=aut&message.id=2169#M2169

                   

                   

                   

                   

                  • 6. Re: Server Script Error 100
                    slemson
                       Thanks for the reply.  I wish the news was better.  Oh well...  Bot client it is.
                    • 7. Re: Server Script Error 100
                      durniak

                      Yikes!  Just wasted about 2 hours on this

                       

                      finally did a Google search on "Server Script Error 100", and found this thread

                       

                      this is nuts, because no error code is generated in the server log.  I had to store the error code in a field, to see it.

                       

                      I managed to export as CSV to the "temp" directory, then flip to the other hosted file, and import as CSV

                       

                      what a pain!

                       

                      greg

                       

                       

                      • 8. Re: Server Script Error 100
                        aconfusedmakeruser

                        Sorry to revive this issue.  I'm just confused about the knowledge base article regarding server-side scripts and importing. 

                         

                        I'm working with a client who already has had a developer create scripts.  The script essentially performs a find for records created or modified  based on timestamps stored for each record, the system time and a stored variable set at the end of the script noting the last time the data was checked for changes.  Essentially just a find for modified or new records.

                         

                        The script is scheduled to run nightly as a server-side script in FMS 10.  The script, found in db1.fp7, looks for the updated/new records and stores them as a found set.   The script then triggers an Import script in db2.fp7 which deletes the current records in db2.fp7 and imports the data from the found set in db1.fp7. I think these were originally written to just run from within Filemaker client but are now setup to run as scheduled from FMS.  There is no transformation or export of the data to any other file format from db1.fp7.

                         

                        My question is whether this should this be working at all as a server-side script? 

                        I'd like to know before the client goes back to the developer with questions that I may raise without having a full understanding of FMS.  I don't want to put the developer in a bad light with client if they should work, but for some other reason are not now.  If my reading comprehension is any good, I'm assuming this should not work as planned.

                        • 9. Re: Server Script Error 100
                          mrvodka

                          A server side import / export can not be done directly with anoher FileMaker file. However, you could export it as another format to the proper location, then a second script import into the other file.

                           

                          That being said, depending on your number of records typically in a found set, you may want to just look into a loop that grabs the data from the first table, and create records in the second table. You can even use a third file that just references the tables in the source and target files and run the script from that file.

                          • 10. Re: Server Script Error 100
                            BasBoss

                                 Not Sure if this will solve some issues for you but i had the same problems with a FM12 Server script.

                            Case:
                                 An automated scheduled script must delete all records from a certain filemaker table and import records from a csv file

                            Result:
                                 No import was performed
                                 Filemaker server Log gave back 2 errors:

                                   
                            •           Error 3 (Command is unavailable)
                            •      
                            •           Error 100 (File is missing)

                                 After hours of frustration I remembered someone once saying something about FMS's default folder for databases and scripts.

                            Test:
                                 I put my csv file in FMS's default documents Folder (Windows: C:\Program Files\FileMaker\FileMaker Server\Data\Documents)

                            Result:
                                 At first FMS imported the records succesfully but still gave the Error 3 message.
                                 When I ran the script again this Error 3 also disappeared.

                            Conclusion:
                                 My fairly unsupported conclusion is that FMS only imports files which are located in the default FMS folder even though I specified a custom location for FMS to host the databases.

                                 The Error 3 only occured when my table was containing 0 records which leads me to believe that FileMaker throws an Error 3 not because the command is unavailable but because there are no records to be deleted.

                                 I Hope this helps some of you. My problem is solved with this solution so i'm not going to test any further to see if my conclusion is valid but feel free to do so.