1 2 Previous Next 19 Replies Latest reply on Aug 23, 2010 10:06 AM by AdrianGorman

    Still Can't Connect

    AdrianGorman

      Title

      Still Can't Connect

      Your post

      I have been trying to set up FMPSA 11 and am struggling to get a connection.

      I have been able to connect locally with my 192.168..... but cannot make a connection with my Static IP address.

      I have set my router up to forward to port 389 with the correct IP address for my PC which is hosting FMS but cannot get it to work (it did work with FMPA iwp - just not the server).

      Can't find anything not configured. Incidently, when i run online port checking softward it reports back no ports open)

      Can anyone please help, the address is

      http://212.84.114.108:389/fmi/iwp

       

       

        • 1. Re: Still Can't Connect
          nilsw

          Is there a reason you are using port 389?

          Nils

          • 2. Re: Still Can't Connect
            AdrianGorman

            Not sure what i am doing is the answer to that.

            I beleive that I set my router (BT2700HGV) up to forward to a port and I thought port number 389 - (saw that in the db sever tab).

            After reading some other stuff I have now changed my router port forwarding to port 5003.

            I can see the DB home page as well as the example db I uploaded into the FMS, but cannot test if it works from outside my network. Those I have asked to try it report back that it is not working.

            My new (recently aquired it for the purpose of IWP) Static IP is 212.84.114.108 but I am not sure if I should be doing anything else with this IP address

             

            • 3. Re: Still Can't Connect
              nilsw

              try setting up a different port, at least on the public interface of the router. Browsers should not be able to connect to a protected port. Also 389 is normally used for LDAP i think.

              Are you trying to grant access to FileMaker sharing or IWP/CWP? FM sharing uses 5003 but you need a client to connect to the host. Your url reeds "http" so I assume you are trying to share your database for browser access. You rather should use port 80 (or 8080) then.

              Nils

              • 4. Re: Still Can't Connect
                AdrianGorman

                Yes, my users would log in via the web browser from outside the UK - Not many, but more than 5 so I wanted to see if we could use FMS.

                I will change the port routing to 80 (or 8080) and see if that works. FMS pro Adv 11 is installed at present on my laptop, and if I can get it to work we will but a PC to host the server.

                I have also switched off the laptop (windows 7)  firewall to see if that helps.

                • 5. Re: Still Can't Connect
                  AdrianGorman

                  Tried port forwading to port 80, and then to 8080 and I still cannot make a connection from outside my own network. I have even turned off Windows 7 firewall.

                  I have also tried a different router (netgear) but that still does not help.

                  Do I need to change the network adapter settings on my laptop regarding the static IP address I now have ?

                  Very frustrating when you do not know what you are doing !!

                  • 6. Re: Still Can't Connect
                    nilsw

                    what ist the locally working url?

                    • 7. Re: Still Can't Connect

                      Adrian Gorman:

                      If I go to Open Remote and add 212.84.114.108 as a favorite host, I am able to see the shared Task Management database. This indicates a proper port forwarding and firewall setup for port 5003. If the web publishing page works locally, can you verify that the settings on your router and firewalls are the same for both port 80 and port 5003?

                      The web publishing should only require port 80 to be open externally (or port 443 if using SSL). When you create a default web site in IIS, you should be able to see it remotely by going to:

                      http://212.84.114.108

                      This page should be accessible whether FileMaker Server is installed or not.

                      TSuki
                      FileMaker, Inc.

                      • 8. Re: Still Can't Connect
                        AdrianGorman

                        Hi,

                        I have checked my router and port forwarding to my hosting PC is set for 80, 8080, and 5003. when I go to http://212.84.114.108 on a remote PC or the PC with the server installed on it nothing comes up ('...cannot display page').

                        I know that I am missing something.

                        IWP is activated on the server and the info says thet it is IIS server.

                        Maybe I should begin again

                         

                        • 9. Re: Still Can't Connect
                          nilsw

                          forwarding generally works, your "task management" is publically accessable. can you connect locally with your browser?

                          @TSuki: can you fix your comment please... the display is somehow messed up

                          Nils

                          • 10. Re: Still Can't Connect
                            AdrianGorman

                            I have tryied to connect with another network outside our office and when I put URL http://212.84.114.108/fmi/iwp all I get is a not found or cannot connect page.

                            I have uploaded another example database to the server - are you saying that you can connect to it ?

                            (the message displayed on the forum is broken for some reason?)

                            • 11. Re: Still Can't Connect
                              nilsw

                              again: what is the local url (http://192.168...) and does this work for you?

                              • 12. Re: Still Can't Connect
                                AdrianGorman

                                                                            The Local URL is http://192.168.1.20/fmi/iwp  which works fine.

                                • 13. Re: Still Can't Connect
                                  nilsw

                                  so the port is definitively 80 and the problem is the router. sometimes routers use/reserve the 80 for remote management even if this is deactivated. please try the following: 

                                  • see, if some settings can be changed in that way, that the 80 can be used for forwarding.
                                  • if not, try to set up a port translation (forward to port different from the receiving: 212.84.114.108:8080 -> 192.168.1.20:80
                                  • if thats not possible you must try to change the port settings on the iis for iwp
                                  • 14. Re: Still Can't Connect
                                    AdrianGorman

                                    I have set the port forwarding to 8080 and 5003 as well as 80. all of these are open in windows firewall (I created a separate rule)

                                    I also tried another different make of router last night will no success. I am struggling with the understanding of networking and maybe should go back to using FMPA with iwp, which worked fine with my static IP address and router.

                                    How would I change the port settings on iis.

                                    thankyou for your help

                                     

                                    1 2 Previous Next