4 Replies Latest reply on Oct 24, 2012 10:45 AM by philmodjunk

    Uploading db to fmserver error

    spliceguy

      Title

      Uploading db to fmserver error

      Your post

           Having converted an fp5 db to fp7 I am getting a db not valid error message when trying to upload it to an fm11 server. It opens and works no problem in FMpro 11 advanced.

           (MAC OSX 10.6)

      Screen_shot_2012-10-15_at_12.40.11.png

        • 1. Re: Uploading db to fmserver error
          AnswerFeedback_1

                I would open it in 11 and do a Save a Copy As..

                

               Then try to re-upload the the new Copy to the server.

          • 2. Re: Uploading db to fmserver error
            philmodjunk

                 You might also perform a recover on the file and try uploading the recovered copy.

                 Things to keep in mind about Recover:

                 While Recover almost always detects and fully corrects any problems with your file...

                   
            1.           The recovered copy may behave differently even if recover reports "no problems found".
            2.      
            3.           Recover does not detect all problems
            4.      
            5.           Recover doesn't always fix all problems correctly
            6.      
            7.           Best Practice is to never put a recovered copy back into regular use or development. Instead, replace the damaged file with an undamaged back up copy if this is at all possible. You may have to save a clone of the back up copy and import all data from your recovered copy to get a working copy with the most up to date information possible.
            • 3. Re: Uploading db to fmserver error
              spliceguy

                   Thanks,

                   I have tried both these options and still no joy. The only way I have been able to do this was by creating a new fp7 db in fmp11, exporting data from the converted file, manually copying the layouts, fields, links,scripts etc across to the new blank db, then importing the data  into this new db, then , finally the fmp11 server will recognise it and serve it as it should.

                   Trying to use a clone didn't work, either balnk or with data added.

                   I tried recovering the file...

                   I tried save a copy as...

                   I tried converting the fp5 to fp7 several times, on each occasion it was successful, and opened in fp11, it was only the server that did not recognise it.

                   My method is quite laborious and susceptible to human error!

              • 4. Re: Uploading db to fmserver error
                philmodjunk

                     And not normally needed, but perhaps there was some issue with the file that could not be corrected by Recover...