2 Replies Latest reply on Aug 12, 2015 11:25 AM by JeffBroderick

    Web Direct operation changed after public IP address changed - can't access

    JeffBroderick

      Title

      Web Direct operation changed after public IP address changed - can't access

      Your post

      Hi,

       

      Using an iMac running Yosemite 10.10.4

      Not sure what has happened but I have the Server 14 Developer version and was able to get Web Direct working for the one concurrent connection I have - locally, using the 10.0.1.3 server address and previously, using the public IP address to access it remotely on iOS and other computers remotely. 

      Now, after moving and finally having a little time to set up, I am accessing it locally just as before but when I use the Server menu to try and open a test page or when I try to access off local network with the public IP address, it just errors out and says cannot connect to server.  The ports 5003, 443, and 80 are all still set the same on the 10.0.1.3 DHCP address.

      I feel like I'm forgetting something dumb but I can't find anything else specific in the Web Direct Guide.

       

        • 1. Re: Web Direct operation changed after public IP address changed - can't access
          steveromig

          Jeff -

          Thank you for your message.

          What was involved in your move?  Was other network hardware introduced (wireless, router, firewall, etc.)?

          I would verify that the IP address has not changed.  It might also be worthwhile to restart the Web Publishing portion of FileMaker Server and/or restart FileMaker Server in its entirety.

          TS_Shark
          FileMaker, Inc.

          • 2. Re: Web Direct operation changed after public IP address changed - can't access
            JeffBroderick

            Hello,

             

            It was the same hardware, etc.  The public IP address has changed.  That was the only thing different as far as I know.

            I notice when I try to open a test page that the IP address chosen is the same as the Web Server IP Address.  

            I did turn off and restart FileMaker Server after my post, after upgrading to 14.0.2, but still same performance.

            It works normally when I enter the FileMaker Server IP Address while on the same network.  Is it supposed to be a simple matter of entering the public IP Address when outside the local network or is there other secret sauce.  

            Do I need to reinstall the files with Sharing now that the public IP address has changed from the move?