1 Reply Latest reply on Jun 28, 2011 9:02 AM by TSGal

    Web Server Test Failed. Problems with Apache? Firewall?

    cresal

      Title

      Web Server Test Failed. Problems with Apache? Firewall?

      Your post

      I'm trying to get IWP working on my server. I'm sorry if this has been solved in earlier posts. My initial search for old posts produced nothing terribly helpful.

      I'm a newbie to servers, and yet one of the most knowledgable one in the office because i know what an IP address is *facepalm*. And I'm the only one that really knows Filemaker.

      This is aso the first time I've really been working with a Mac. Far more accustomed to Windows.

      Server info:

      Mac OS X Server, version 10.5.8

      exceeds minimum requirements to run FM Server Advanced

      I'm attempting to install the trial version of FM Server Advanced 11

      I downloaded the trial, installed without a problem and got the admin console up and running without a hitch. I got it hosting our poor outdated database and accessible to other computers on the network, no problem. But when I started going through the steps to enable web publishing I ran into a hiccup. While using the deployment assistant I made it to the step where "the following web server has been located and can be used for web publishing" > Apache
      But when I click next it takes me to the error screen "Web Server Test Failed" with the error

      "Unconfigured web server...
      Return code = 0"

      Testing web server...
      Return code = false"

      I manually input our host IP and port 80, and got

      "Retry web server test...
      Web server test failed. Return code = -1"

      I thought maybe the port was being blocked. On some reading online I went into sharing preferences but didn't even see web hosting listed as an option to change settings for. i thought i'd try a different track and change the port apache was using, but i searched and searched and couldn't even find apache settings anywhere. after following multiple mac forum posts about apache i determined that i didn't think apache was *actually* up and running on the server. So I downloaded MAMP ( http://www.mamp.info/en/index.html ) so that I could at least be sure Apache was up and running. Got that going, no problem, tested it, it seems to be hosting properly as far as I can tell. I changed the Apache default server to 80 instead of 8889 (default set by MAMP), and everything still looked fine. I went back to FM Server and tried again, but still no luck. I changed back to default port set by MAMP, still returning an error code on retry. On the advice of FM phone tech support I uninstalled and reinstalled FM Server with Apache already up and running, but I'm still getting the same error code.

      The closest thing to an IT guy around here (he's actually the accountant, just happens to know slightly most about computers than most) says that our firewall is set up through our cisco box, and that we need to talk to them if we need to change any firewall setting *headdesk*.
      So I don't know how else to find out if our firewall is blocking the ports I need, or if that's even the problem, or how to change Apaache settings or even if I've inadvertently created a double of Apache.

      Halp? What step might I be missing to get this web publishing up and running?