2 返信 最新の回答 日時: Jan 8, 2009 11:04 AM ユーザー:Matthew1

    ソート順でスペースが認識されない

    humbucker

      タイトル

      ソート順でスペースが認識されない

      フォーラムに投稿

      FileMaker 9.0v3を使っています。ソート順でスペースが認識されないのですが、仕様でしょうか?

      もしくは回避方法等あれば、ぜひ教えてください。

      よろしくお願いします。

        • 1. Re: ソート順でスペースが認識されない
          humbucker
            

          すみません、補足です。

          文頭のスペースを認識しません。ソートすると無視されてしまいます。文中のスペースは認識してソートしているので、文頭のスペースもなんとか認識させられないものでしょうか?

          • 2. Re: ソート順でスペースが認識されない
            Matthew1
              

            こんにちは、humbuckerさん。

             

            フィールドの頭にある空白文字(U+20)はソートでは無視されるようです。ソートの言語設定に「日本語」を使用しないのであれば、[レコードのソート]ダイアログにて言語設定を「Unicode」にすることによって空白文字などすべての文字を対象にしたソートをすることもできます。

             

            通常の空白文字の代わりに Option-スペースバーで入力できる改行を行わない空白文字(U+A0)を使用した場合、ソートの言語設定を「日本語」にしたままでもソートは可能になります。

             

            に Matthew により編集されました