7 Replies Latest reply on Sep 14, 2015 10:11 AM by MattLeach

    Printing Single Labels with Dymo 450

    MattLeach

      Some time ago i created an inventory database to keep track of all equipment within our organization. This database incorporates barcoding. Up until now, i printed out barcodes on a full sheet using avery 5160 lables. This worked, but anytime i added a new item to the database and needed a barcode i couldn't print just one label.

       

      To rectify this i purchased a Dymo LabelWriter 450 Turbo label printer. After 2 days of fighting with it i've all but given up.

       

      As a precursor, I'm using FMPA14 on a MacMini. Database is hosted on FMS14

       

      I have a hardware table which contains a container field that stores the barcode.

       

      I created a new layout with just the contained field on it that uses the same Hardware table. As a note - i tried creating a label layout using both the layout wizard as well as creating one manually.

       

      I created a print button and attached a script that simply goes to the the new layout and prints the barcode. Well...instead of getting the barcode for the record i was on, i get the barcode from a completely different record. What i also find strange is no matter which record i print a barcode from, i always get the same barcode. While viewing the layout, the correct barcode is displayed. I looked at the print options and it was set to print all, so i changed it to print the current record only, now when i print i get nothing, just a blank label.

       

      With that in mind, i figured i would try something different for troubleshooting. I created a new table called barcode with 2 field, one for the hardware ID which i set as a global and one for the barcode (container) that does a lookup of the barcode from the hardware table.

       

      I created a script that will set the hardware ID which in turn performs a lookup of the barcode. So now i have a table with 1 record, 1 single barcode. No matter if i set the printer to print all, current records, recording being browsed, etc... i still get a blank label??

       

      Any ideas what may be going on?