13 Replies Latest reply on Dec 7, 2015 5:08 AM by wimdecorte

    WebDirect Stops working !  HELP

    binu.alexander

      Screen Shot 2015-09-28 at 1.07.18 PM.png

       

      Seeing this error today ....

       

      This my setting ....

      I have also enable web direct in Extended Privileges in my database  ....

       

      Screen Shot 2015-09-28 at 1.07.11 PM.pngScreen Shot 2015-09-28 at 1.07.46 PM.png

        • 1. Re: WebDirect Stops working !  HELP
          wimdecorte

          Where are you seeing that error, when you go to the webdirect page in a browser?

           

          What do FMS logs themselves say?

          • 2. Re: WebDirect Stops working !  HELP
            binu.alexander

            Yes when I go to the page in the browser ... I still see this error

             

            Logs dont show anything .... The dont show  any record today ... Last entries were > 12 hours ago

             

             

             

            I have no issues with accessing using FM Pro client .... I have been using it often during the last 8 hours

             

            Screen Shot 2015-09-28 at 5.08.59 PM.png

            • 3. Re: WebDirect Stops working !  HELP
              binu.alexander

              http://forums.filemaker.com/posts/8387f84a8b

               

              This post has something similar .....   I am not able to fix it  still

               

              Maybe TSGal can help me out ....

              • 4. Re: WebDirect Stops working !  HELP
                TSPigeon

                binu.alexander:

                 

                It seems that Webdirect is enabled and both the WebServer and Web Publishing Engine are in good working order, but the WebDirect page (IPAddress/fmi/webd) shows that WebDirect is turned off. The Forum Post you referenced is related to the error when XML/PHP are enabled and WebDirect is turned off -unrelated to this issue.

                 

                First, you may want to verify you are deploying in an ideal environment. For the System Requirements of FileMaker Server 14 see Knowledge Base Article #14401.

                 

                You may also try restarting the WebPublishing Engine. This can be done by running the command: “fmsadmin RESTART WPE”.

                 

                Redeploying would also be a great step. You can redeploy by going to the Server menu in the top right of the Admin Console and selecting Edit Deployment.

                 

                I hope this information is of use and I look forward to your response.

                 

                TSPigeon

                FileMaker, Inc.

                • 5. Re: WebDirect Stops working !  HELP
                  binu.alexander

                  Thanks

                   

                  I have tried

                   

                  1) Restart  WPE  using          fmsadmin  RESTART WPE

                   

                  2)  And Redeployed  … Succesfully

                   

                  3) My Server is high class server grade machine with 64GM RAM and Xeon Processor ,  1 TB HDD    ( has been working well for > 1 year )  No issues there I think

                   

                  4) I rebooted the server completely also

                   

                   

                  SAME  ISSUE STILL  ….

                   

                   

                  Please let me know what to do ….  My clients are locked out !

                   

                   

                  Thanks

                   

                   

                   

                  *******************************************

                   

                  Dr. Binu Alexander

                  Bridge Connectivity Solutions,

                  New Delhi - 110045, India

                  +91 7508331659

                     

                   

                  • 6. Re: WebDirect Stops working !  HELP
                    TSPigeon

                    binu.alexander:

                     

                    Thank you for your response.

                     

                    At this point I would recommend to Save your Schedules and Groups, uninstall FileMaker Server, rename the FileMaker Server Folder, reboot, and reinstall the latest update of FileMaker Server. However, that won’t tell you the cause. Are you running on a dedicated machine?

                     

                    Any anti-virus or backup software scanning the FileMaker Server Folder could cause damage. Backup software should be running only on the Backups of your databases, not the whole FileMaker Server Folder. Anti-virus should not be scanning the FileMaker Server Folder.

                     

                    Are you hosting any other websites or running any other hosting softwares alongside FileMaker Server?

                     

                    You can find more information on the deployment of FileMaker Server in the Getting Started Guide.

                     

                    TSPigeon

                    FileMaker, Inc.

                    • 7. Re: WebDirect Stops working !  HELP
                      sibrcode

                      This might be a bit different then your issue, butI've been having something similar on our dev server, and just recently on a client system too.

                       

                      We do see the most of the WebDirect login screen briefly, but it is then quickly replaced with the spinner.

                      The FMS logs have no useful clues, including the ones at HTTPserver/logs.

                       

                      However the browser's console does give some relevant info:

                       

                      [Warning] Unexpected CSS token: : (styles.css, line 1)

                      [Log] Vaadin websocket push patched (vaadinPush.js, line 25)

                      [Error] WebSocket network error: OSStatus Error -9807: Invalid certificate chain

                      [Warning] Websocket closed, reason: Connection was closed abnormally (that is, with no close frame being sent). (vaadinPush.js, line 25)

                      [Warning] Websocket closed, wasClean: false (vaadinPush.js, line 25)

                      [Info] Websocket failed. Downgrading to Comet and resending (vaadinPush.js, line 25)

                      [Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (PUSH, line 0)

                       

                      One difference between the two systems is that on one, the part of WebDirect we do see briefly has the red box about the SSL certificate being self-signed, but the other does not.

                       

                      All other functionality works: CWP, XML, FMP, admin console. Just not WebDirect.

                       

                      Since others have access to both systems I can't be completely sure, but as far as I know, both systems were previously working and hadn't had any major changes to their settings before this issue occurred.

                       

                      In these two cases they are both OSX based systems.

                      • 8. Re: WebDirect Stops working !  HELP
                        binu.alexander

                        Fixed !  Reinstallation helped .... I will check with the Server Admin if the backup software is backing up the entire folder or not .....

                         

                        My server is a dedicated VM ... no other sites being hosted on the same VM

                        • 9. Re: WebDirect Stops working !  HELP
                          mardikennedy

                          Do you think that it might have been related to this FMS v14.01 issue?  (I think the updates have fixed this?)

                          Webdirect login not comming up

                          • 10. Re: WebDirect Stops working !  HELP
                            binu.alexander

                            I was already using 14.03

                             

                            Sent from my iPhone

                            • 11. Re: WebDirect Stops working !  HELP
                              mardikennedy

                              my mistake - thought I'd seen a mention of 14.01

                              • 12. Re: WebDirect Stops working !  HELP
                                binu.alexander

                                This happened again today !    Last time I did as you suggested and re-installed everything ... it worked ..

                                 

                                Now do i reinstall each time ?

                                • 13. Re: WebDirect Stops working !  HELP
                                  wimdecorte

                                  Does it work again after you restart the web publishing engine (either from the admin console or from the command line)?