2 Replies Latest reply on Sep 29, 2015 8:29 AM by gtorborg77

    Problems with ODBC connection to FMPro database

    gtorborg77

      I was originally going to post this about a month ago, but other questions on this issue partially solved my problem.  Now I have a new question, related to the first.

       

      I have built a FMPro 12 database that uses an ODBC external data source for most of its tables.  I initially had a problem with the fact that the default DSN in Windows 7 is 64-bit while FMPro 12 is 32-bit, but that's the problem I eventually got solved.  Now, I have uploaded the database to our FileMaker Server (12) and opened it there, and ran into the problem of it not being able to see the server (MS-SQL) referenced in the ODBC data source until I added the 32-bit version of the driver.

       

      But now that I have it all set up, I get this problem:  it continuously asks me to log in to the ODBC database source (see screenshots below) but tells me I cannot.  I'm using the same username and password for this as when I do it using a local database with the same connection, although when I perform the actions below in my "local" database, I am not prompted to log in at all. 

       

      Please note the attached screenshots for further explanation of what's happening.  Figure 1 is my ODBC control panel.  Of the 5 DSNs shown there, only BUDD32 can be seen by FileMaker Pro.  (Both it and the BUDD64 can be seen and used by other software such as Microsoft Access.)  Figure 2 is two screens ahead (I skipped the one that shows the database server to which it connects) to show the options I set up there.  Both DSNs (on the FMPro server and the local PC) are set up the same way.  When I started to have problems, I switched it to the middle option and had my username and password "hard wired" in place; this didn't make any difference at all.  Figures 3 and 4 show the rest of the configuration setup.  Remember, both the one on my computer and the one on the FileMaker Server are set up identically.

       

      In the FMPro database, I go to File -> Manage -> External Data Sources where I get the screen in figure 5.  Figure 6 shows the configuration of the data souce, both the way it worked in the local copy as well as the way it doesn't work on FileMaker Server.  On the latter, I did try the middle option here, hard coding my username and password in that box, but it made no difference.

       

      Then, when I go to File -> Manage -> Database, and click the Relationships tab, I get Figure 7, showing the only local table in the database.  When I click the button on the bottom left to add a table, I get Figure 8.  I then change the data source to the BUDD32 DSN, and get Figure 9.  I do not receive the prompt in Figure 9 at all when using my "local" database.  When I put in my user name and password, I get Figure 10.  Note that the dialog box comes from Filemaker Pro.  I tried entering my username and password for a FileMaker-authenticated account in the database, but this doesn't work either.  I have double-checked to make sure that I am entering my correct username and password for the server in question on our campus; I am doing it right.  But nothing allows me to get past this screen for the sake of adding tables to this database when it is open on the FileMaker Server.

       

      Any ideas, anyone?