13 Replies Latest reply on Mar 18, 2016 12:16 PM by swheeler

    Script Workspace won't open

    dinoapolito

      I'm going crazy.

       

      Suddenly I cannot open the Script Workspace. Whatever method I try - File menu, keyboard shortcut - I can't get to my scripts. I've tried over multiple solutions and even started a new one.

       

      Has anyone encountered this craziness?

       

      FMP14A

       

      Cheers

      Dino

        • 1. Re: Script Workspace won't open
          dtcgnet

          I'd try quitting and restarting FM as a first step.

          • 2. Re: Script Workspace won't open
            dinoapolito

            Did that a couple of times. Even turned the computer off and on again

            • 3. Re: Script Workspace won't open
              dtcgnet

              In the Scripts menu, is Scripts Workspace greyed out for some reason? Are you on 14.0.1 or on 14.0.2?

              • 4. Re: Script Workspace won't open
                dinoapolito

                No it's not greyed out. The current window seems to lose focus as if the scripts window has opened but it's nowhere to be seen. 14.0.2

                 

                My guess is a screwed registry setting which I'm guessing is where the last opened position is stored.

                • 5. Re: Script Workspace won't open
                  dtcgnet

                  Go to the Window menu, and look there. If the Script Workspace is open, but somehow got shoved off to the side, Script Workspace would show up in the list of windows. That will at least tell you it's open.

                   

                  Quit FileMaker. Restart. Go to the FileMaker menu, to preferences. At the General tab, you'll see a button for Reset dialog sizes and positions. Click that.

                  • 6. Re: Script Workspace won't open
                    TSPigeon

                    dinoapolito:

                     

                    Thank you for your post.

                     

                    I believe dtcgnet’s (thank you) suggestion should resolve this for you. Another possibility on the Windows Operating System is to hit “Windows Key + Left Arrow” or “Windows Key + Right Arrow” after clicking the Script Workspace to snap the window to the left or right of your screen.

                     

                    I hope this information is of use!

                     

                    TSPigeon

                    FileMaker, Inc.

                    • 7. Re: Script Workspace won't open
                      dinoapolito

                      Thanks for your suggestions.

                       

                      Unfortunately none worked although I have since tracked down and fixed

                      the problem. The last time FMP was opened and the Script Workspace used

                      it was through a Remote Desktop session and on a large Apple Cinema

                      monitor at high res. The scrip workspace was way over in the bottom

                      right hand corner.

                       

                      The subsequent session was on the native computer with a much smaller

                      monitor at lower resolution. Filemaker was 'opening' the Script

                      Workspace at a position that was not there hence it could not been seen.

                      Killing the Windows Registry fixed the problem as would have simply

                      opening it again through the RD session and moving it over before

                      closing down again.

                       

                      Thanks again,

                      Dino

                      • 8. Re: Script Workspace won't open
                        brianpatterson

                        The one time I had it happen, I somehow had gotten two instances of the database open at once. The one I was working on was called my database 2

                        • 9. Re: Script Workspace won't open
                          swheeler

                          I am currently having this issue in Windows 10.

                           

                          At work I have multiple displays and keep my workspace and debugger on the secondary monitor to the left. When I remote desktop from home (laptop with windows 10) and I open my workspace it will not appear on the screen nor can I access it with any of the methods mention above. Prior to my work computer being windows 10 (previously win7) I could use the window key + right arrow key to move the script workspace into view during my remote desktop session, this is no longer the case.

                           

                          Any ideas?

                          • 10. Re: Script Workspace won't open
                            TSGal

                            swheeler:

                             

                            With the file not open, pull down the Edit menu and select Preferences...

                             

                            Click on the "General" tab, and next to the option "Reset dialog sizes and positions:", click "Reset".  This will place the Script Workspace, Debugger, etc. back to the original position on the primary monitor.

                             

                            TSGal

                            FileMaker, Inc.

                            • 11. Re: Script Workspace won't open
                              swheeler

                              Hi TSGal,

                               

                              This does not function as expected, the workspace is still off screen, even after FM restart.

                              • 12. Re: Script Workspace won't open
                                TSGal

                                swheeler:

                                 

                                I just installed FileMaker Pro Advanced 14.0.4 on Windows 10.  I created a database file, opened Script Workspace, and placed it far off to the left (I only have a single monitor).  I closed and reopened the file, opened Script Workspace, and it remains in the far left position.  I closed the file, went into Preferences, and reset the dialog sizes and positions.  I then reopened the file, opened Script Workspace, and it now appears in the middle of the screen.

                                 

                                After reading my last reply, I realized I made a mistake.  I initially said, "With the file open".  I should have said "With the file not open".  I have updated the post.  My apologies.

                                 

                                TSGal

                                FileMaker, Inc.

                                • 13. Re: Script Workspace won't open
                                  swheeler

                                  Worked like a charm!

                                   

                                  Thanks for the help and have a great weekend!