6 Replies Latest reply on Feb 21, 2016 11:20 AM by Vincent_L

    Updating Filemaker Server v14 problem

    siplus

      Today I received a new MacMini bound to be a server for a small client. Came with 10.10.4.

       

      N.B. For small clients (3-5 users), we install OS X Server, Filemaker app and Filemaker Server on the same machine.

      Above that we dedicate the MacMini to FM Server only and get another MacMini for the rest.

       

      installed, updated to 10.10.5.

      Restart. Repaired privileges. Used Onyx to take away animations, ran through sys preferences to disable/set things etc.

      Restart: everything worked fine and flawless.

       

      Anyway: at this point, I wanted to update FM Server from 14.0.2.226 to 14.0.3.302. Downloaded updater.

       

      The updater started and froze on "27 elements to install". Of course, the server was closed, databases were closed, Safari with Admin console was closed, etc.

      I restarted, same thing.

       

      Then I restarted, but with holding down the shift key. Updater did its thing in 5 seconds, no freeze, no problems.

      Restarted again, everything ok.

       

      For what it's worth, posting it.

        • 1. Re: Updating Filemaker Server v14 problem
          jamiebah

          I had the same issue, the FMS 14 V3 updater would freeze at "Items remaining to be installed: 27", the only way "out" is to force quit the updater.

           

          Doing a force quit of the updater on my iMac (several different times) caused no problems with FMS.

          Doing this on my client's Mac Mini (one time) caused issues with FMS, FMS Adminserver, and other FMS component(s), they all failed to start, I could not start them from the command line, nor would they start after a reboot.

           

          Based on your post Siplus, I thought about what would be different when restarting with no extensions, one major thing would be that none of the Mac OS X Server processes would be running.  So...

           

           

          Solution:

          I tried removing the OS X Server App from the Applications folder and, after a minute or so, the update started. 

          (I did this while the installer was still "frozen")

          I then moved the OS X Server App back to the Applications folder after the FMS update was finished, opened Mac OS X Server and let it do its thing, everything seems to be working fine.

           

          I thank you for the post, it helped me find the solution.  I don't know if I would have though to remove the Mac OS X Server App without the idea of "no extensions"

           


          Additional Info:

          I tried the update with Mac OS X Server 5.0.15 and, I had also tried with the previous version of Mac OS Server X 5.0.x on my iMac, but on the client's Mac Mini, I only tried with version 5.0.15.


          Computer Info:

          Late 2012 iMac

          • 3.1 GHz i7
          • 16GB Ram
          • 10.10.5
          • Fusion Drive
          • MacOS X Server 5.0.15
          • FMS 14.0.2

           

          MacMini Mid 2010

          • 2.66 GHz Core 2 Duo
          • 4GB Ram
          • 10.10.5
          • Software mirror of internal drives
          • MacOS X Server 5.0.15
          • FMS 14.0.2

           

           

           

          RANT / PLEA / IDEA:

          It would be nice if FileMaker would make it easy to view the install/update log file, I have no idea where to find it, IF its available.

          I am guessing that being able to see what was happening would have made it easier to figure out what was causing the freeze.

           

          FileMaker Inc., PLEASE LET US SEE THE LOG FILES FOR UPDATES AND INSTALLS!

           

          Better yet, use an Apple installer package instead of the Vise X installer.  Apple provides the log file access I am wishing for by pressing cmd-L.

          • 2. Re: Updating Filemaker Server v14 problem
            TorstenBernhard

            This seems to be an issue encountered by quite a few people. The workaround (given by Tech Support) is to wipe the 14.0.2 installation and install 14.0.3 from a full installer (contact Tech Support in order to getting) it. The hang on your system maybe related to the http and https port numbers.

             

            See this thread for more info FSM 14.0.3 for OS X updater issue 

             

            And yes, getting a log from the install process would help. +1 for your request.

            • 3. Re: Updating Filemaker Server v14 problem
              siplus

              I'm happy it helped.

               

              Restarting with shift key down from time to time, then doing a normal restart, is IMHO a good thing anyway.

               

              From Apple:

               

              What is safe mode?

              Safe mode (sometimes called safe boot) is a way to start up your Mac so that it performs certain checks, and prevents some software from automatically loading or opening. Starting your Mac in safe mode does the following:

               

              • Verifies your startup disk, and attempts to repair directory issues if needed

              • Loads only required kernel extensions

              • Prevents Startup Items and Login Items from opening automatically

              • Disables user-installed fonts

              • Deletes font caches, Kernel cache and other system cache files

              • 4. Re: Updating Filemaker Server v14 problem
                jamiebah

                I just had the same problem with Server 14.0.4 on the same iMac (same OS version) listed in my previous post about FM Server 14.0.3.  It was "hung" at 2xx things to install.

                 

                This time, I made sure to stop all web services in the MacOS Server App, I waited a few minutes and nothing happened yet, so I checked the Activity Monitor (Utilities Folder), and there were several httpd processes still running, using the terminal, I did a "su" command to elevate myself to an administrative user, then executed the following command:  sudo killall httpd

                (See security note for further explanation)

                 

                In a matter of seconds the Server 14.0.4 installer then finished, no need to uninstall and re-install from a "full" version, or remove the MacOS Server App from the Applications folder as I stated in my last post.

                 

                I would have to say that Torsten is correct in that it has something to do with the httpd process.  As to port number(s) being the issue, I'm not sure how they come into play here, unless its that fact that I was using non-standard port numbers for FMS and the installer was expecting to find httpd on standard ports.  FileMaker Inc. could easily fix this by looking at the port numbers specified for web publishing during the initial install of FMS.

                 

                 

                Security Note:

                In order to use the sudo command in a default install of MacOS, the user trying to execute the sudo command must be an administrator of the computer.

                My user account on all my computers is a standard user, no matter what the OS as it is considered a "best practice" to always setup a separate Administrative user and do your "normal" activities as a standard user

                • 5. Re: Updating Filemaker Server v14 problem
                  jlg89

                  jamiebah's solution worked for me as well. FileMaker installer was hung copying files, I dragged Server.app out of the Applications folder, and the FileMaker installer immediately came back to life.

                   

                  It's frustratingly ironic that FileMaker doesn't play well with Server.app.

                  • 6. Re: Updating Filemaker Server v14 problem
                    Vincent_L

                    "sudo killall httpd"

                     

                    wow many thanks it saved my 14.0.4a install that was stuck