8 Replies Latest reply on Nov 9, 2015 12:29 PM by eoin

    iOS 9.0.2 AirPrint on FMGo 14.0.3

    eoin

      Environment

      FMS14  hosted solution and iPad 3 or Air 2 running iOS9.02 and FMGo 14.0.3.

       

      Symptom.

      Button Script in a list view form sends the user to new record on a print layout (Works)

      User enters data (2 fields) and then clicks a print button which runs a script to print to an AirPrint printer and return back to the list view.

      Problem I am having is with a printer error dialogue. If the printer is low on toner Air print flashes up a warning dialogue after the print job has been sent. Click OK on the dialogue and the screen goes grey, the target list view form does not appear.

       

      Touch the screen and the list view screen appears, but the FMGo app has become very slow and un responsive some times.

      Quit the FMGo app with a button script to exit application works but any attempt to relaunch the file just flashes the screen.

      Solution to the relaunch issue is to double click the home button and swipe the FMGo app upwards to kill it.

      Launch FMGo again and everything runs fine until print error dialogue appears.

       

      Work around is not to return to the list view within the print script but have another button on the print layout with a goto layout script step.

       

      Other issue I am having is with small Star TSP100 Lan Thermal printers, In the new iOS print dialogue there is a print preview, If I press the print button immediately the the layout is reduced in size (shrunk). If I wait for 5 seconds the print Preview seems to re-scale the layout to match the paper size shown. Possibly and more likely a direct iOS issue, but will make printing a real pain going forward.

        • 1. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
          TSPigeon

          eoin:

           

          Thank you for your post.

           

          Have you been able to produce a sample file which replicates this issue and if so can I get a copy to send to Testing and Development for review?

           

          I look forward to your response!

           

          TSPigeon

          FileMaker, Inc.

          • 2. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
            eoin

            Hi TSPigion,

             

            I have had mixed results trying to replicate this behaviour in a "Clean" file, yet it exists in re written layouts and scripts in my own file.

            What I have noticed is the script step "goto layout" after the print will fail if the "print without dialogue" is checked.

            In the sample file I am attaching when hosted on FMS14.2 and run on FMGo 14.0.3 on iOS9.0.2 if you print the record with "Print with dialogue" and close the database it will re open.

            However if you print the record with "Print without dialogue" and close the database ... it will not re open.

             

            The printers I am using are wireless Star TSP100 and the layout is formatted for them. They are small thermal tally roll printers 72mmx160mm.

            We use Lantronix Printserver to make them visible as AirPrint Printers.

            What I am noticing on my network is when I select the printer I have to wait about 5-8 seconds for the print preview to resize the print image correctly for the paper size. Any attempt to print before this resizing occurs will result in minute print on the Star.

             

            These errors are not specific to the star printers. I have had issues printing to HP laserjet 400 (fully Airprint Compatable) which also seem to interrupt the script flow if they issue a low toner or low paper warning during the script.

             

            Printing on iOS with AirPrint was always clunky but worked, now on iOS9 it is very troublesome.

            • 3. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
              TSPigeon

              eoin:

               

              Thank you for your response.

               

              I am going to forward this information and your post to Testing and Development. When I receive any feedback I will let you know!

               

              TSPigeon

              FileMaker, Inc.

              • 4. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
                TSPigeon

                eoin:

                 

                Thank you for your patience.

                 

                Testing and Development did receive the “The printer is low on ink” warning message but were unable to reproduce your issue with an iPad Air 2 in iOS 9.1 or a iPad 2 in iOS 9.0.2. They wanted to know if it is possible for you to test this under iOS 9.1 on your devices?


                I look forward to your response!


                TSPigeon

                FileMaker, Inc.

                • 5. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
                  eoin

                  Hi TSPigeon,

                   

                  While testing and development have been examining this file I have discovered the whole issue with the files stability is dependent on if the print without dialogue option is selected or not in the script step.

                   

                  My environment is this test file hosted on

                  nMacPro 6 Core 32Gb Ram OSX 10.10.3

                  FMS14 v 14.02.226 FMGo 14.0.3

                  Any iPad running any version of iOS 9.0 through to 9.1(beta5) Problem does not exist on iOS8.4.3

                   

                  Host the file on the server.

                  connect to the server(local) and open the file on the iPad.

                  Create a new record, enter product code & quantity.

                  Press the "print with dialogue" button on the layout and the record prints to the printer. Everything works!!!

                  Create a new record and do exactly the same using the same print with dialogue button on the layout ... everything still works.

                   

                  Close the file and open it again on the iPad .. everything works

                  Close the file on the server ... file closes normally.

                   

                  So everything has worked as expected thus far.


                  Open the file again on the server

                  Connect to the server (local) on the iPad and open the file.

                  add new record, enter product code & quantity

                  Now this time press the "print without dialogue" button on the layout, the record prints on the printer. Everything seemed to work.

                  However .... if you try now to create a new record, you have no access to the dropdown list...

                  If you close the file on the iPad .. you can not reopen it without first killing the FMGo App (double click home button and swipe FMGo upwards)

                  If you try to close the file on the server the file will show closing and the file will never close properly.


                  For me any time I press a button that calls a print script which happens to have print without dialogue option enabled in the script step FMGo 14 and iOS9x does not like it.



                  Interim solution is to have specific print scripts for iOS9 devices which do not have print without dialogue enabled.

                  I have attached the file again after downloading from the server.


                  Perhaps this time it will display what I am seeing.

                  I may have initially thought the low toner dialogue was the issue, but I have eliminated that and in my opinion it is directly related to the without dialogue option in the print script step.



                  • 6. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
                    TSPigeon

                    eoin:

                     

                    Thank you for the detailed response.

                     

                    I'm glad to see you've narrowed it down this far. I will add this information to the report. It is still definitely unwanted behavior. I will add any additional response from Testing and Development to this thread.

                     

                    TSPigeon

                    FileMaker, Inc.

                    • 7. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
                      TSGal

                      eoin:

                       

                      This issue has been addressed in FileMaker Go 14.0.4.

                       

                      TSGal

                      FileMaker, Inc.

                      • 8. Re: iOS 9.0.2 AirPrint on FMGo 14.0.3
                        eoin

                        Excellent news, thanks for the update!.