2 Replies Latest reply on Oct 13, 2015 1:46 PM by Malcolm

    Value List Options truncated when formatted as Radio Buttons

    Malcolm

      Windows 8

      FileMaker Pro 14.0.2

       

      In browse mode the value list options are truncated when formatted as radio buttons.

       

      One or more characters are truncated. In some cases one or more words are truncated.

       

      In some cases, the option is replaced by a question mark. In cases where a question mark is displayed, the option will be displayed when the mouse is hovering over the field however, the display is affected by the truncation bug being described here.

       

      Mouse hovering does not affect the display of options that have characters or words truncated.

        • 1. Re: Value List Options truncated when formatted as Radio Buttons
          TSGal

          Malcolm:

           

          Thank you for your post.

           

          This appears to be an extension of your similar posting at:    Truncated Radio Button Text

           

          Since this post contains screen shots, I'll repeat the questions from my other reply here.

           

          Is the value list a custom list or based on a field?

           

          How many items are in the value list?

           

          What font and size is being used for the field?

           

          Are you using a built-in theme or a custom theme?

           

          Is there any conditional formatting applied to the field?

           

          If you save to PDF and open the PDF file, does it show correctly?  If showing correctly, what printer and model is being used?

           

          There are issues when the screen display settings are greater than 100%, so make sure this is set at 100%

           

          Any other information you can provide may be helpful in narrowing down the possible causes.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Value List Options truncated when formatted as Radio Buttons
            Malcolm

            This appears to be an extension of your similar posting at: Truncated

            Radio Button Text <https://community.filemaker.com/thread/148837>

             

            It is the same issue from the same file and could be joined together.

             

            I submitted separate reports because I could see different behaviour

            occurring when FileMaker Pro was running a different version of the

            Windows operating system.

             

            Since this post contains screen shots, I'll repeat the questions from

            my other reply here.

             

            My replies below are exactly the same as my replies to your other reply.

            Is the value list a custom list or based on a field?

             

            The issue affects custom lists and list based on a field. Two of the

            value lists are based on fields and in both cases the value list uses

            two fields and only the second field is displayed.

             

             

            How many items are in the value list?

            This issue is affecting fields using many different value lists. The

            shortest list contains two items. The longest lists contain eleven items.

             

            What font and size is being used for the field?

             

            The font is Helvetica Regular 16. There are no attributes applied, ie,

            neither bold, italic, underline nor hiliter are used.

             

            Are you using a built-in theme or a custom theme?

             

            The file was created before themes were introduced. Classic theme has

            been applied during conversion using FMPAdv 14.

             

            Is there any conditional formatting applied to the field?

             

            Conditional formatting has not been applied to any of the fields that

            are affected.

             

            If you save to PDF and open the PDF file, does it show correctly?  If

            showing correctly, what printer and model is being used?

             

            The problem is evident in the PDF.

             

            When opening the file in FMP 14 on Windows 8 the problem appears in

            browse mode and it is evident in PDF. When opening the file using

            Windows Ultimate 7.1 the problem is not evident when in browse mode,

            however a PDF generated from that layout displays the problem.

             

            Any other information you can provide may be helpful in narrowing down

            the possible causes.

             

            The file was created originally with v9. It has been running on FMSA v11

            for several years. It was recently converted to the new file format

            using FMA14 and placed onto FMS v14. The problem is not evident on Mac

            OS X.

             

            malcolm