9 Replies Latest reply on Oct 19, 2015 1:11 PM by TSGal

    Font issue

    ErichWetzel

      Have been using FileMaker Pro 14.0.2 on Mac OS 10.10.x with good result recently.

       

      Changed for FileMaker Pro 14.0.3 and Mac OS 10.11 and font handling has been a particular problem. Printing has been a notable problem. We have fields that are formatted for Helvetica and print showing boxes rather than text characters. The text shows up just fine on screen.

       

      In one instance it prints fine when using Helvetica as Plain Text but throws boxes when printing text formatted as Condensed.

       

      In another instance it prints every field properly except one. All fields are in this case are formatted Helvetica 12, 14, or 16.

       

      Do you guys have any suggestions?

       

      Thanks

       

      - Erich Wetzel

        • 1. Re: Font issue
          ErichWetzel

          Recreating the offending field seems to resolve the issue in at least one instance. Recreating the field could be a real inconvenience considering the number of times this has come up already especially in situations where we have complicated tab orders.

          • 2. Re: Font issue
            TSGal

            ErichWetzel:

             

            Thank you for your posts.

             

            How many fields do you still have displaying the issue?  Whatever displays in Preview is what should be sent directly to the printer driver.

             

            There have been a few reports of Adobe temporary font files interfering with fonts in FileMaker Pro.  The solution in those cases is to reboot the computer, as this will then remove the Adobe temporary files.  Have you tried this?

             

            TSGal

            FileMaker, Inc.

            • 3. Re: Font issue
              ErichWetzel

              Yes we have tried rebooting. Each login on our system requires a reboot due to issues apple has yet to resolve for network users.

               

              Each circumstance has been duplicated by different users on different client machines.

               

              We have been fixing problems manually as they show up. I do not know how many may be left.

               

              Erich Wetzel

              • 4. Re: Font issue
                TSGal

                ErichWetzel:

                 

                Was this file created in FileMaker Pro 14 or a previous version?

                 

                You said that "Recreating the offending field seems to resolve the issue in at least one instance."


                For those other instances, have you found any resolution?  If you create a new layout (do not duplicate) and add the offending field to the new layout, does it print correctly?


                TSGal

                FileMaker, Inc.

                • 5. Re: Font issue
                  ErichWetzel

                  TSGal,

                   

                  The file was created in previous version.

                   

                  For the instances where I did not have the convenience to recreate the field, due to problems that would cause, I changed fonts. Changing fonts solved the problem. We have some old font files that are less and less compatible as time goes by. So we have gradually moved to ones that are more or less standard like Helvetica. The odd part was that in every instance, the fonts rendered fine on screen. The printed output was the only time this was a problem.

                   

                  Unfortunately our files and printing layouts are sufficiently complicated that quickly making up a new one has usually not been a time convenient thing to do.

                   

                  Erich

                  • 6. Re: Font issue
                    TSGal

                    ErichWetzel:

                     

                    I'm still having difficulty determining if this is a file issue, layout issue, object issue or font issue.  If possible, I would like to see a clone of your file so I can test it here.  I have sent you a private message with instructions where to send the file.

                     

                    TSGal

                    FileMaker, Inc.

                    • 7. Re: Font issue
                      ErichWetzel

                      TSGal

                       

                      Before I trouble you with deeper issues and sending you a copy of the file, I have tested this further. The fonts we are having trouble with are mostly ones that come out of the early and mid 1990s. I have tested the following:

                       

                      New layouts and new fields do not seem to actually solve the problem. If I choose the fonts I know are issues they do not print properly no matter whether it is an old or new layout, or old or new field.

                       

                      For clarity ALL fonts show properly on the screen.

                       

                      Some of the ones I have, such as a narrow version of Helvetica, are not part of the default Mac OS and are add ons we have made. So I am thinking this is a compatibility issue with the older font files.

                       

                      Is there a suggestion beyond removing the troublesome fonts from our databases? They all worked as expected in FMP 13.x and 14.0.2 and only changed in the shift from Mac OS X 10.10.x to 10.11 which happened at the same time as FMP 14.0.3.

                       

                      How about if I send you a font file and see if you can confirm the issue is the font there?

                      • 8. Re: Font issue
                        ErichWetzel

                        Additionally in looking at the Font Book.app for the computer, it is not complaining about incompatibility with any of the fonts we have had the printing trouble with.

                        • 9. Re: Font issue
                          TSGal

                          ErichWetzel:

                           

                          I have access to both Mac OS X 10.10 and Mac OS X 10.11 computers, so feel free to send in one of the fonts.  I'll check to see if it is a Mac OS X or FileMaker issue.  Use the same information in the private message when sending in the file.

                           

                          TSGal

                          FileMaker, Inc.