2 Replies Latest reply on Oct 19, 2015 1:55 PM by dreed

    Problem Enabling Web Publishing on FMS 14 (Win2012R2)

    dreed

      Hi All,

       

      I've been mostly running FMS12 on a VMWare box for several years with no trouble, but now I'd like to update to the latest server and have had IT spin up a fresh VM running 2012R2 for me.  I can enable IIS with the default website as mentioned in the getting started, and run the FMS installer and deployment assistant to completion except when I have any Web Publishing checked during deployment (or during edit deployment if I try to enable it after the fact).

       

      During the deployment assistant, right after choosing "single or multi machine" deployment, the deployment assistant will hang and become unresponsive.  I can see error messages appear on the hung assistant saying:

      SETUP: PRECONFIGURE WEB SERVER: passed

      Test web server (http://127.0.0.1:8080/fmi-test/test.xml): Error code = 500

       

      This seems to indicate some kind of internal error, but I'm not sure how to fix it.  It doesn't seem to matter whether I use port 80 or 8080 or whatever on the FMWebSite that appears in IIS Manager on FMS install.  There definitely seems to be a screw up in IIS with regard to the FMWebSite, and any help troubleshooting would be appreciated.

       

      Thanks!

       

      Dana

        • 1. Re: Problem Enabling Web Publishing on FMS 14 (Win2012R2)
          dreed

          Hi Again. 

           

          Though this didn't turn up in my initial search on the forum for install issues.  This link answers the exact question I have above

           

          Thanks!

           

          Dana

          http://forums.filemaker.com/posts/91198d0960

          • 2. Re: Problem Enabling Web Publishing on FMS 14 (Win2012R2)
            dreed

            Just in case that link goes bad if the old forum site goes away, I'll paste in the list of things that need to be uninstalled here to get a fresh start on reinstalling FMS

             

            The installation will enable and configure IIS, so do not enable IIS prior to the installation.

             

            Is the operating system Windows Server 2012 Standard and not R2 or another flavor?

             

            If the IIS role is removed and then the server is redeployed, does deployment succeed?

             

            If not, then perform the following steps for a clean wipe of all necessary components and then reinstall:

             

            1. Uninstall all of the following from Add/Remove:

             

                a. FileMaker Server 13

                b. Java (all versions)

                c. Bonjour

                d. IIS URL Rewrite Module

                e. Microsoft Application Request Routing

                f. Microsoft External Cache for IIS

                g.  Microsoft Visual C++ 2012 Redistributable Package (x64)

                h. Microsoft Web Farm Framework

             

            2. Remove the IIS role from Server Manager

            3. Restart the computer

            4. Delete the inetpub folder located on the C:/ drive

            5. Delete or rename the FileMaker Server folder located on the C:/ drive

             

            Afterwards, reinstall FileMaker Server 13.0v5/9 with the full installer from your store email or the article below.