3 Replies Latest reply on Oct 21, 2015 11:31 AM by hschlossberg

    Interactive Container field w/ pdf not working in FM14

    jdevans

      Product and version- FMA14.0.2

      OS and version- Windows 7 Pro 64 bit

      Description- I have a layout with a large container field which, in FM13, displayed a pdf inside the field on the layout. Now in FM14, when I land on the same layout, the Adobe Acrobat X Pro application starts up automatically and opens the contents of the container. The container remains blank.

      How to replicate- Open layout with interactive pdf container field using FM14.

      Workaround NONE.

        • 1. Re: Interactive Container field w/ pdf not working in FM14
          jdevans

          Update: I ran the latest updater file for fmpa, and it still behaves as before. No change.

          • 2. Re: Interactive Container field w/ pdf not working in FM14
            jdevans

            I just got off the phone with FM Support.  I reported what I perceived to be a bug- in FM13, our Timesheet PDF layout displayed the pdf right there in the container field if it was set to interactive. Now in FM14, the pdf never displays in the container field, rather it opens in the default pdf program- in my case Adobe Acrobat X Pro.

             

            Lo and behold, the way it is behaving now is the way it was designed.

            The other problem now is, if I put a pdf file in a container field, it shows blank but opens automatically in Adobe Acrobat. Yet if I put a powerpoint file in there, it shows a powerpoint icon with the name of the file. If I put a picture in there, it displays the actual picture file. This is so confusing. In my opinion, these container fields need a lot of work from the Filemaker developers.
            It is so unpredictable as to what it will do, based on the type of file inserted.
            • 3. Re: Interactive Container field w/ pdf not working in FM14
              hschlossberg

              This is a bug that is documented here: http://help.filemaker.com/app/answers/detail/a_id/15155/ , though I know a couple developers for whom this article didn't pop up in the results when searching for something as obvious as "open pdf".

               

              It is fixed by updating the version of Acrobat you have.  Well, that's a terrible answer, but it is a workaround.

               

              FMP is 64-bit. Before updating the Acrobat version to the latest, the only Acrobat I had installed was Acrobat Reader 11. The "Adobe PDF Reader" add-on shows in IE as being 32-bit, even though IE* is 64-bit (and yet the browser still displays PDFs, I guess as a 32-bit window, since IE10 and 11 display as 32-bit or 64-bit depending on the content).  (*I refer to IE because FM's web viewer and container fields are based on the Windows Internet Explorer engine.)

               

              I've now reverted back to Acrobat 11 as the newest one sucks, and I think the answer to any clients who have similar problems with PDFs in Acrobat on Windows just have to be told that the feature doesn't work.  That's what I've been telling them for years anyhow, as it has never, EVER worked properly with FileMaker on Windows.

              3 of 3 people found this helpful