2 Replies Latest reply on Oct 27, 2015 2:40 PM by TSGal

    ODBC Data Source Missing

    JonathanCoulter

      I have FMP Advanced 14, 32-bit, installed on my Windows 7 Pro workstation and I'm trying to get ODBC working again.

       

      I successfully installed the 32-bit driver a month or so ago and it was working fine. Not any longer.  The ODBC Administrator (yes, I'm using the 32-bit flavor) kept telling me to reinstall the driver.

       

      I tried the "repair" option within the installer, but that did nothing.  I uninstalled the Filemaker ODBC driver and reinstalled it.  Now when I go into the ODBC Administrator and try to "add" a data source, Filemaker does not show up.  Yep, ODBC is turned on in Filemaker Server.  And yep, I rebooted just to be sure.  And no, I haven't tried a bigger hammer ... yet.

       

      Any ideas? 

        • 1. Re: ODBC Data Source Missing
          JonathanCoulter

          I finally got the ODBC working, but I'm getting the "Filemaker (212) No Such Account" error.  I have an excel spreadsheet that links to a filemaker table.  It was working just fine a week ago.

           

          How do I get around this error?

          • 2. Re: ODBC Data Source Missing
            TSGal

            JonathanCoulter:

             

            Thank you for your posts.

             

            If you got the ODBC working, should I assume you clicked Test to verify it was correctly configured to access the database?  If you didn't click Test, go through the ODBC Data Source Administrator again and verify each step.  If the test still returns an account error, make sure:

               1. The database file is hosted and available

               2. The FileMaker account uses a privilege set with the extended privilege Access via ODBC/JDBC

               3. FileMaker Server or FileMaker Pro host application has been set up for sharing via ODBC/JDBC

             

            Keep me updated with any progress.

             

            TSGal

            FileMaker, Inc.