4 Replies Latest reply on Nov 12, 2015 6:13 PM by ipointsystemadmin

    Minimal and Full Indexing problem... resolved, but why?

    PeterWindle

      Hello all!

       

      Today, I was investigating a problem with a "Status" field, which only contained one word, per record (no returns).

       

      When searching in that field, the search worked perfectly for all status values, with the exception of one.

      When performing a searched for the word "booked", I received a batch of records which included other values, such as "Completed" etc...

       

      I went into the records and checked the values within the fields, they all looked perfect. Only 1 word value in the field and that's all, no extra or un-expected characters.

       

      Of course, performing an exact match search "==booked" worked, but not on the word itself.

       

      This was odd, to say the least. Upon inspecting the field indexing, it was set to "Full", so I changed this to "Minimal" which fixed the problem, however, it still does not make sense why this did not work with Full indexing, since searching for all other status values worked fine, plus the values in the field of "wrong" records found where normal... which would indicate that the index is fine.

       

      So, my guess is, that the "full" index was still storing previous values that where once in that field and have since been replaced?

       

      I realise that the indexing should have been set to Minimal to begin with, however, the thing is, this is un-expected behaviour, regardless.

      FM Pro 14 on Windows.

      Anyone else seen something like this? Bug? Feature? X-Files?