craigufm

Auto-Enter Not Working Properly During File import

Discussion created by craigufm on Nov 12, 2015
Latest reply on Nov 19, 2015 by TSGal

Product and version (e.g. FileMaker Pro 12.0.5 or 14.0.4)

OS and version Mac 10.10.5

Browser and version (for WebDirect only)

 

Description:  


The auto-enter function is not working properly to auto-enter data, serial numbers or other content during the import of files.  I have used this function for many years in Filemaker but it is no longer working. 


I am using two files -- target and source.  SEE ATTACHED SCREENSHOTS.


Source has first name, last name, email address fields which are populated with that data in each field.  Target has first name, last name, email address, and a fourth text field which is used for auto-entry of data.  First name and last name are empty, email address has an email address. 


The fourth field in the target is set as an AUTO ENTER TEXT field (auto enter is chosen), DATA is chosen, and I have entered the letters YES in the auto-enter data section and clicked OK. 


When I do the import, I choose IMPORT in the target file, and then select the SOURCE file as the source.  I clicked UPDATE MATCHING RECORDS IN FOUND SET and I set the email field as the MATCH field with arrows pointing in both directions.  SEE ATTACHED SCREENSHOTS.


When I click IMPORT, the import occurs and brings in the first name and last name for 125 records that have matching email addresses (as expected).  This is correct.


But the FOURTH field of the target (the auto-enter field)...remains blank.  The YES from the auto-enter DATA does not come in.


I have also tested with auto-enter fields that use CREATION DATE, MODIFICATION DATE, TIME, and CALCULATION or SERIAL NUMBER.   The date and time come in fine for all matched records.  The others (serial number, calculation) do NOT.


I have tested many variations of this in both Filemaker 12 and 14, and have tried on various Mac computers.  I have closed and re-opened Filemaker several times.


The AUTO ENTRY IMPORT DIALOG BOX does not usually appear, although this behavior seems intermittent.  Sometimes it appears (and I click to PERFORM AUTO ENTER during import), but sometimes it does not appear at all (despite all other things being the same -- and verifying that we have an AUTO ENTER field properly set up).


The problem still occurs even WHEN the PERFORM AUTO ENTER dialog DOES display and we click to enable it;  the data for the auto-entry field does NOT populate the field even in that case, when using auto enter DATA, NUMBER or CALCULATION.


I have performed this sort of auto-entry hundreds of times over the years, but it is not working now.  My Mac updated to Yosemite 10.10.5 some time ago, but I have found no notice online that this could be the issue.  I called Filemaker for assistance, but they wanted to charge me to escalate to a technician, which I find ridiculous for a basic function that has always worked.


Please see screenshots and advise if you have encountered this same issue or know of a fix.


Thank you

 

 



How to replicate See above

Workaround (if any)  could not find one

Outcomes