AnsweredAssumed Answered

AccessDenied using BE_ExecuteSystemCommand on Filemaker Server

Question asked by freppan on Nov 19, 2015
Latest reply on Nov 19, 2015 by freppan

Hi,

 

Stuck and hoping that some brilliant mind(-s) can point me in the right direction.

 

I got a script where I create a zpl-stream in a text file and then copy that file to a Zebra label printer using BE_ExecuteSystemCommand. I would like to do it that way so that I can run the script on server using Go or WebDirect.

 

This is what I run:

BE_ExecuteSystemCommand ( "cmd.exe /c copy " & $StreamFileNamePath & " \\\192.168.28.85\prtlblkontor64 /b" ; -1 )

 

All the time on the same windows machine (the test server): It works great using FMP and also typing it in at the windows command prompt. However when i run it on FMS it returns: "Access is denied. 0 file(s) copied."


Any suggestions? The shared printer is set on the print server to allow "everyone" to print on it and like I wrote above I can access it using FMP or manually using cmd. It should probably also be mentioned that the test server running FMS is not on the same domain as the print server.

 

(I have also tried using BE_CopyFile instead without success.)

 

Hope I managed to give all the info needed. Many thanks,

Fredrik

Outcomes