3 Replies Latest reply on Nov 23, 2015 11:09 AM by wfgclapp

    Unable to 'lock' a screen from 'floating' in FMGo

    wfgclapp

      Running FM Pro, Server, and Go 14.

       

      I am creating a new Go app, sized for iPhone6 portrait. I have sized my layout (including top and bottom nav bars) to be 375 x 636 px. I have all toolbars and status bars hidden.

       

      Problem: When I bring up my layout in Go on iPhone6, the body of the layout floats vertically. It's as if I made the layout too large for the device screen size. But even if I drastically reduce my layout height, the problem remains.

       

      To note: Once I've brought the floating layout up in Go, if I pinch the screen it squeezes down then snaps back and at that point on it no longer floats. But as soon as I close the file and go back in, I'm back to vertical floating.

       

      Startup script:

      Show/Hide Menubar [Lock ; Hide]

      Show/Hide Toolbars [Lock ; Include Edit Record Toolbar ; Hide]

      Set Zoom Level [100%]

       

      In my startup script I have taken those three scrip steps and tried just about every combination I could, i.e. order of script steps, lock on/off, different zoom levels, etc.

       

      I have searched around for posts about this and found nothing, which leads me to believe I'm missing something very easy.

       

      Anyone out there have any thoughts?

       

      Thanks!

        • 1. Re: Unable to 'lock' a screen from 'floating' in FMGo
          skywillmott

          Ah yes, I also discovered this problem - i.e. the opening layout having 'rubber-banding', even though set to display as a 'Form' and with all content sized to fit within the screen area. Navigating away from the layout and then returning to it seems to make it behave as expected, i.e. no rubber-banding.

           

          It seems to only occur when you use Top and Bottom Navigation Parts on your opening layout. Using Header and Footer parts instead results in no rubber-banding. However, I have found that it is better to use Nav Parts as they cause less screen 'flash' or jiggle when moving between layouts in FMGo 14.

           

          The fix I use is to create an empty 'opener' layout (with only a 'Body' part - no headers/footer or nav parts), with a transparent object on it with all Autosizing anchors turned off - this causes the layout to fill the screen on all FMGo devices. I then have a 'startup' script that checks if the file is being opened using FMGo and then sets zoom lock to 100%, toolbars and menubar hidden, locked etc.., and then crucially doing a 'Refresh Window' before immediately going to my actual 'start screen' layout that has the Top and Bottom Navigation Parts etc.. This start screen now has no rubber-banding.

           

          In 'File Options', I set it so that toolbars are hidden, 'Switch to layout' is set to my 'opener' layout, and then a script trigger set to run my 'startup' script 'OnFirstWindowOpen', which leaves the user on the desired 'start screen' layout with no rubber-banding.

           

          See attached screenshots of the 'File Options' settings, the 'startup script, as well as an attached sample file.

           

          cheers,

           

          Sky

           

          file_options.pngscript.png

          1 of 1 people found this helpful
          • 2. Re: Unable to 'lock' a screen from 'floating' in FMGo
            wfgclapp

            Sky,

             

            Thanks a bunch, I can't wait to try this. Worried i wasn't explainin the issue well, but it's great to find when someone else knows exactly what you're talking about and knows how to fix.

             

            Might not get to it today but I will tomorrow. Will let you know.

             

            Thanks again,

            martin

            • 3. Re: Unable to 'lock' a screen from 'floating' in FMGo
              wfgclapp

              That did the trick. Thanks Sky!