ibrahim_bittar

FileMaker, Web Services and SHA-2

Discussion created by ibrahim_bittar on Dec 6, 2015
Latest reply on Dec 6, 2015 by taylorsharpe

Hi all

 

At this point I'm not sure if this is a FileMaker problem or not so I come here hoping someone can shed some light.

 

In Mexico, we have something called "electronic invoicing", which basically is we send every invoice we create to the Mexican tax authority via web services. There are a group of certified providers and you can choose the one you like.

 

We have been working with one provider for 5 years without a problem. I created a plugin with ScriptMaster that does all the web service consumption through a library called ws-lite. A few months ago, our provider announced that they were moving to SHA-2 certification and given that I could do everything in their testing environment I assumed that it would be OK when they'd go live, which was this past Friday.

 

WRONG

 

Now, every solution we have that consume the web service under Windows fails miserably and only I get "ERROR" as a response. If I run the Groovy script from the ScriptMaster solution (the FileMaker file that comes with the plugin) it works, but if I create a plugin and try to use the web service from Windows then it fails.

 

On mac it works perfectly. May be part of my error was to assume that it would work without problems just because it worked on my mac.

 

The thing is that now I'm stuck. The only solution I could find was to call the service without SSL encryption (http instead of https).

 

Before diving into the Groovy - WSLite world I'd like to know if any of you have been able to use a web service with SHA-2, may be with POST and BaseElements plugin.

 

Best regards

 

Ibrahim

Outcomes