ResoluteSystems

FMS 14.0.4 Web access broken

Discussion created by ResoluteSystems on Dec 13, 2015
Latest reply on Dec 14, 2015 by ResoluteSystems

This is a similar issue to the one reported by JEDtech:

FileMaker Server 14.0v4 Update Breaks Web Services

 

The details are different in this case. WebDirect, html files and file uploading by FMP are all failing to connect. I’ve tried every suggestion I can find in forum posts and elsewhere, all to no effect. Any help from FM tech support would be most welcome. The details are copied below.

 

Colin

 

+++

 

Host is a 2012 Mac mini, dual core, 8 GB memory, single machine.

 

Originally running OSX 10.9.

 

FMS 13 updated to FMS 14, then to 14.0.4. WebDirect and FMP upload problem started.

 

FMS 14 uninstalled.

 

OS X updated to 10.11.2.

 

FMS 14.0.4 installed from a full installer.

 

FMS 14.0.4a patch applied.

 

GoDaddy standard SSL cert installed and recognised as supported in FMS Console. In FMS Console, switching Off SSL makes no difference.

 

OS X firewall Off, Murus firewall On, ports 80 and 443 enabled. Disabling the firewall makes no difference.

 

Database access privs look fine.

 

FMnet and FM Go seem fine.

 

No access to WebDirect or html pages from from Safari 9.0.2:

    Safari can’t open the page “<webaddress>” because Safari can’t connect to the server “<ipaddress>”.

 

In FMPAdv 14 / File / Sharing / Upload, trying to connect returns “Connection failed”.

 

I guess FMS remote admin will fail for the same reason but haven’t tried it.

 

In the file /Library/FileMaker Server/HTTPServer/conf/extra/httpd-ssl.conf, the line 65 statement appears correct as described by JEDtech. The file /usr/local/bin/fmsgetpasskey file exists.

 

+++

Outcomes