4 Replies Latest reply on Dec 17, 2015 4:11 PM by ontarget

    WebDirect Crashing V14 fields locking in find mode

    ontarget

      FileMaker V 14 (14.0.4) Dec 16 2015

      Hosted on FMPHosting Pro's in USA

       

      Unfortunately this is not one problem but several:

      1. Random crashes where the spinner shows on the screen and you have to exit and re-login.
      2. The above problem does not always occur, so I checked with a hosting company and they rebooted. This problem reoccurs on different applications so it's not related to just one application.
      3. in a previous conversation I was having problems with reports missing the first record after the sub summary. After testing, I realize that the reports were originally designed in FileMaker 12. So I re-designed the layout for the current version and deleted the old reports. This corrected the missing elements in the report. But now I have a new problem where in find mode fields that are set to be able to be browsed, and those that are set only for find mode are locked? I checked the help in FileMaker Pro, and found no information to assist in finding the problem. I checked this forum and did not find anybody displaying this particular problem. I checked the field size, check the padding, I even edited the scripts in different ways to see if I could stop this from happening. Is anybody else seeing this issue?
      4. I was also seeing an issue where the canned report script initiated a pause, and when I removed it or canceled it from the top of the screen where it was shown in Web direct it exited the find. Everything that is not working in Web direct was retested in FileMaker Pro advanced in its function normally. I removed the pause portion of the script for the auto report script, but the problem still persists with the fields not allowing me to add them or edit them to the find. In browse mode on the report screen I can click into the field and get a drop-down, or insert but in find mode the field if I click on it to access it in the find causes the server to show the spinner or crash out right. Now this happens on more than one application.
      5. The hosting company feels that it is FileMaker server, Web direct where they have seen this problem in the past on other client applications. I have seen this issue since version 14 was released.
        • 1. Re: WebDirect Crashing V14 fields locking in find mode
          crm

          Sounds very similar to the chronical crashes I encountered when running long scripts with many subscripts with many subloops, specially when search and craeate record activities are in there.

           

          So far no clear result what really causes.

          After cleaning up the longest of the scripts, the troubles vanished.

          To me it looks a bit like speeding up certain processes between FM and OS X that go as far as risking crashes. I sent them more than 20 crash reports. No thankyou, no answer from Apple. FileMaker Germany at least tried to help what they could.

          • 2. Re: WebDirect Crashing V14 fields locking in find mode
            ontarget

            December 17, 2015

             

            I spent the better part of yesterday testing to try to determine if there was a workaround fix the issues in this question.

            I reached out to a few other developers to see if they were having this issue. One comment got my attention that the recent upgrade for version 14 of Web direct server had some issues. I contacted my hosting company and they assured me they had the latest version the corrected this issue.

            Another developer I spoke to addressed padding is an issue; padding is required in Web direct so that no field or header or other element on the screen either touch or overlap. I have three reports where I'm having the fine mode fail to open and work correctly. On the first report I gave padding to all elements on the screen so that the objects would not overlap or touch. This did ease the problem were now the fields that have drop downs or edit entry were allowing me to access that field.

             

            There was still a problem with random spinner crashes back out to the login screen.

            On the second report that I was editing I increased the size of the field height to 21 pixels as I did on the prior report, and I made sure that all the objects were clear of each other. I immediately started having problems with the spinner crash back to the login window required. This wasn't random was more of a constant in that when I click on fields the entire report flashes. Then the spinner shows and continues until you go back and re-login.

            Every object on the screen had a field Heights changed and all objects are clear of one another, and yet I'm still getting the spinner crash. Keep in mind this was not an issue until the day before yesterday. All the reports were working and I had no spinner crashes. Something was introduced that change the functionality and I believe it was the server update.

             

            Needless to say this is a showstopper for all my clients who are using Web direct on the cloud! This is an urgent issue in that businesses are unable to use a database that worked correctly just two days ago.

            To recap even after all the objects on the screen are not touching and there is correct padding, many of the objects on the screen do not allow the cursor to edit within the field.

            Note: I am using the cool brown theme.

            • 3. Re: WebDirect Crashing V14 fields locking in find mode
              ontarget

              On the question of scripts being too long, this is not even close to the problem. Most of these are simple drop-down or edit fields that when clicked on do not even open or allow editing. My last comment today explains more about the issue that I'm having.

              • 4. Re: WebDirect Crashing V14 fields locking in find mode
                ontarget

                Dec 17 2015

                 

                After lots of testing and contacting other developers, we found it is bugs in the .04 release of FM WebDirect v14. So this question is now resolved. We had to revert to v13 of WebDirect and all the bugs disappeared.