3 Replies Latest reply on Dec 18, 2015 12:49 PM by keywords

    Send email not sending attachment

    garqua

      Hi

       

      I have created a script that sends an email with a PDF file attached. The script was created as the example 2 of the following page Send Mail.

      When an email is generated with dialogs the mail application creates the email and attaches the file with no issues, then i need to manually send it. But when the option perform without dialog is checked the email is sent without the PDF file.

       

      I'm running this script on OS X 10.11.12

      Using Filemaker Pro Advanced 14.0.4

      Default mail application: Mail

       

      Can someone please advise on this.

        • 1. Re: Send email not sending attachment
          steveromig

          Hi

           

          I have created a script that sends an email with a PDF file attached. The script was created as the example 2 of the following page Send Mail.

          When an email is generated with dialogs the mail application creates the email and attaches the file with no issues, then i need to manually send it. But when the option perform without dialog is checked the email is sent without the PDF file.

           

          I'm running this script on OS X 10.11.12

          Using Filemaker Pro Advanced 14.0.4

          Default mail application: Mail

           

          Can someone please advise on this.

           

          This is known issue with El Capitan that we are looking into.  Using / Displaying the send mail dialog as you are already doing is one of the workaround available until this is resolved.

           

          Steve Romig

          FileMaker, Inc.

          • 2. Re: Send email not sending attachment
            garqua

            Hi Steve

             

            Thanks for your fast response. I'll try this again once the fix is available.

             

            Best Regards

            Alfonso Garza

            • 3. Re: Send email not sending attachment
              keywords

              You could also try inserting a pause (1 or 2 seconds, say) between the Save and Send steps in the script. This is to give the OS a chance to "catch up", so to speak.