4 Replies Latest reply on Mar 31, 2016 6:04 PM by vision

    FileMaker Script Engine terminated abnormally

    maddie

      I'm trying to get the 360Work's Email 2 Plug-In to work on my server. Here is what I have done so far:

       

      Installed and registered the Email 2 Plug-In to FileMaker 14 Advanced.

      Installed, shut down and restarted the server, and registered the Email 2 Plug-In to FileMaker Server 14.

      Logged into the server console, clicked on Database Server, Server Plug-Ins, clicked "Enable FileMaker Script Engine (FMSE) to use plug-ins"

      Clicked "Allow Install Plug-In File script step to update Server plug-ins

      Clicked the checkbox to enable the 360Works Email 2 Plug-In

      Saved the Server Plug-Ins tab

      Created a FileMaker script schedule that uses the Email 2 Plug-In material to run every half hour every day

       

      Every time I try to run the schedule manually, or the schedule tries to run every half hour, I get these errors:

       

      Server Events, Information, 146, Schedule "Read Email" now run by "maddie".

      Server Events, Information, 689, Schedule "Read Email" has started FileMaker script "3313s Read Email and Update".

      Server Events, Error, 757, Schedule "Read Email" aborted; FileMaker scripts can't run because FileMaker Script Engine (FMSE) process is stopped. Use the command "fmsadmin start fmse" to start the FMSE process.

       

      Naturally, I opened Terminal and typed in "fmsadmin start fmse" and no new events appeared in the Log Viewer so I figured it was running. So I ran the schedule again manually and I for the same set of errors above. So my next steps were to type in "fmsadmin stop fmse", "y", and then "fmsadmin start fmse". This time I got this in my Log Viewer:

       

      Server Events, Information, 952 FileMaker Script Engine process stopped.

      Server Events, Information, 704, Stopping FileMaker Script Engine process...

      Server Events, Information, 703, Starting FileMaker Script Engine process...

      Server Events, Information, 772, FileMaker Script Engine support of Install Plug-In File script step enabled.

      Server Events, Information, 480, Use of server-side plug-ins: Enabled

      Server Events, Error, FileMaker Script Engine process has been terminated abnormally.

       

      Seeing that, I re-opened my Terminal, typed in "fmsadmin start fmse" and ran the schedule manually. Again, I got the first set of logs once again. So again I typed in "fmsadmin stop fmse", "y", and then "fmsadmin start fmse", got the second set of logs again, typed in "fmsadmin start fmse", ran the schedule manually, and got the first set of logs again.

       

      I don't know what I'm doing wrong. Whenever I run the script manually in FileMaker Pro Advanced 14 the script runs through without a single problem.

        • 1. Re: FileMaker Script Engine terminated abnormally
          KenNewell

          I would double check the script(s) to make sure that they do not contain any steps that are not compatible to run server side.  Use the check box in your script editor to show the script steps compatible with server side scripts.

          • 2. Re: FileMaker Script Engine terminated abnormally
            maddie

            I've double checked the script, all of the steps that I have are Server compatible. Whenever I run the script locally for testing, it does what I've told it to do(read the inbox and "import" the email(s) into a new note record for each email).

            • 3. Re: FileMaker Script Engine terminated abnormally
              jrenfrew

              you're going to need to post the script as otherwise its the most random kind of guessing...

              • 4. Re: FileMaker Script Engine terminated abnormally
                vision

                Just to add to Maddie's unanswered post, I have a user running FMS 14.0.4.413 under Win Server 2008 R2 having the exact problem.  They are running a solution with 6 simple FM scripts run by the server daily.  The solution has been in place for many years with no issue and was updated to FMS 14.0.4 (and FMP 14.0.4) many months ago when these updates came out and has no issues running the server scripts.

                 

                But suddenly 5 days ago stopped running the scripts with the exact same log errors Maddie reports.  Starting and stopping the FMSE via the command line does not result in FMSE function and just gives the same "support of Plug-In ..." error, although this function is not designated as active in the Database preferences in FMSAC and none of the scripts being run or for that mater any script in the solution, uses plug ins.

                 

                Machine has 64GB of RAM, 16GB designated for FMS via FMSAC preferences, and does nothing but run FMS. No recent updates by the user to the OS or known installation of other apps or services. But, auto updates of Windows OS items is turned on (reviewing those currently)

                 

                We will uninstall and reinstall FMS to see if it helps but any additional insight to this issue is appreciated.  Thanks.