5 Replies Latest reply on Dec 30, 2015 4:22 PM by dburnham

    Cannot edit a scheduled script on server

    dburnham

      This is about FileMaker Server 14.0.302 running on a Windows 2012 machine.

       

      Scheduled scripts are running just fine, but they can't be edited.  I select the database and enter the correct user name and password which is a full access account.  One of those HTML-5 yellow pop-up things appears telling me that there are no accounts available for the selected script.  (Not verbatim, but I can't invoke a screen capture fast enough before it disappears.)

       

      Until today, I could just click NEXT a second or third time and the Admin Console would proceed to allow me to edit the script.  Now, it just refuses altogether.

       

      I don't see this problem on other FMServer installations.  What might be the cause and the cure?

       

       

       

      follow-up remarks:

       

      After restarting the server, I tried again.  This time I memorized the pop up message: "No scripts are available for the specified account."  It's just simply an erroneous message, putting it politely, because all the scripts on the server are definitely available for the specified account.  And, thanks to restarting, I can click NEXT to dismiss the stupid message and edit the script, but it still makes no sense at all.

        • 1. Re: Cannot edit a scheduled script on server
          user16545

          Same problem here with FMS14.0.4 on Windows2012 server, see No Scripts are available for the specified account.
          You must indeed keep pushing the next button ten or twenty times until the dialog continues.

           

          However: then the following problem in script scheduling reveales itself.
          It is impossible to create a schedule which runs every 15 minutes or so.
          And the schedule dates seem to be shifted to one day ahead.
          See the picture: this schedule is clearly set to run every 20 minutes: it simply won't do that.

           

          Bugs like these cost us, developers, so much time and effort to find solutions or create workarounds.

           

          Am I the only one with this problem or did other developers notice this as well?
          If so, did you find a solution?

           

           

           

           

           

          Picture.png

          • 2. Re: Cannot edit a scheduled script on server
            user16545

            Second problem with respect to scheduling is solved.
            If you start a new schedule at - for instance - 22.30 and want it to run every 15 minutes during the day, then don't set starting time at 22.30 and end time at 22.15 (next day).
            Set Starting time - for instance at 00:05 on the starting dat and end time at 23:50.

            • 3. Re: Cannot edit a scheduled script on server
              dburnham

              I never ran into the second issue.  I have a script that has run every 3 minutes, reliably for more than 5 years.  I think the only thing that would cause an issue with a short interval between script runs would be if the script did not finish in time for its next run to begin.

               

              However, the main issue is still the fact that "No scripts are available for the specified account." persists as a nuisance.  I have pressed next a half dozen times, but I don't have the patience to go as far as 20 times.

              • 4. Re: Cannot edit a scheduled script on server
                user16545

                Hi dburnham,

                 

                Can you please try to press next until the dialog continues?
                If this works with you as well, then we know that this is a temporary solution until Filemaker comes with a fix.

                • 5. Re: Cannot edit a scheduled script on server
                  dburnham

                  You mean  you want to to press the NEXT button indefinitely or count the number of times it takes to dismiss the "no scripts available" message?   I can tell you that it sometimes takes 1 click, but if 2 clicks don't do it I have no interest in being a guineau pig for this.  It's enough, in my opinion, to report it to FileMaker and let them know about it.  I don't know enough about HTML-5 to understand what makes it happen.