AnsweredAssumed Answered

Need Help with Password Issues

Question asked by EMH on Jan 4, 2016
Latest reply on Jan 4, 2016 by EMH

I posted this on a previous 2011 discussion question but suspect it may be difficult to find given the age and title, so I am creating a new question. I just purchased a new MBP so I thought I'd give FMP (14) a try again after being frustrated with this same issue a few years ago (I used FMP extensively from v.1 - v.9. My desire is to encrypt a db (or I believe they are no called 'Solutions' now); that is I want a PASSWORD to ALWAYS be required, regardless of the account. I installed FMP14 on the new MBP, performed the upgrade, and created a dummy two field file called Untitled. With the db open, I went to File Options-> Open-> Log in Using -> Account Name and Password (though I'd have preferred JUST password). I left the Account as 'Admin' and typed "1234" for the password. I received  the message: "This file will be opened automatically using the specified account. To use a different account, hold down the Option key (Mac OS) ...while opening the file."  All seems well and good, then when I try to open the file using Admin/1234, I get this message: "The account and password you entered cannot be used to access this file. Please try again"   Arrgggh! I tried this numerous times, experimenting with different combinations, sometimes trying to change the admin name, but get the message "The account name and password you entered does not match those for any Filemaker account (when I know they are names and passwords I've used with previous iterations of the 'Untitled DB' experiment).

 

To make matters worse, when I created Untitled 4 BUT stayed in the file rather than closing and reopening it, I went back to the File Options and noticed that the number of dots in the password field had increased significantly from 4 to 20!

 

I also tried leaving the Account field empty and entering the '1234' PW - and got the "The account and password you entered cannot be used to access this file. Please try again" message.

 

Here is all I want to do:

Create a 3 field DB that no matter who the user is, a PW is required to be typed in before the DB info is displayed and I need this to also work on my iPhone in FMP-Go.

 

Can anyone help a fellow out?

 

I will be forever grateful!

 

Signed,

Frustrated in OK

Outcomes