TKnTexas

Found Set is Wrong

Discussion created by TKnTexas on Jan 27, 2016
Latest reply on Jan 27, 2016 by alquimby

I have a solution that is giving me wrong answers.  This is the 3rd month I have used it.  It is only used once a month.  I aggregate transactions for the month, creating invoice data.  This is exported to our accounting software to bill.

 

I am creating invoice 'headers' parent table, from the source of the child table.  I summarize the child records.  I have a layout that has the body and sub-summary.  I can review the data for accuracy.  Then I have a layout (created by duplicating the first) which is the sub-summary only.  I export this sub-summary to an Excel intermediary file, to import back to the parent-table.  Auto-enter fields added other data.  In a portal I can see the child records that made these up.  All worked well until this month.

 

My BillPeriod field is 2016.01.  I do a find on that value that field.  My "annual" and "month" records have a January TranDate.  My "backup" records have a 12/31/15 TranDate.  My Export is done from the Sub-summary layout.  I can view these dates and the BillPeriod.  They are the correct records.

 

When I view the Excel file, I have blank records (3-4) in a row.  I have TranDates of November.  This all worked last month.  The only change was to add an extra field to the export/import.  I have deleted the Excel field.  I have export via script and manually.  I get the same wrong data.  I am at a loss. 

Outcomes