1 2 Previous Next 15 Replies Latest reply on Feb 3, 2016 6:28 AM by eqitec

    How To Hide Scripts in FMGo

    eqitec

      How can scripts be hidden from a guest user's view in the script listing in a FMGo14 App? I already have them unchecked in the Admin master app, and they are not supposed to be accessible in the guest user privileges. Yet, they are showing under FMGo when the user logs in as guest and, worse yet, when they click on one of the scripts, they get a dead end error message saying that they don't have access privileges to run the script. But there's no way out of the error message, so the app is essential unusable after that point. What am I missing. Thanks.

        • 1. Re: How To Hide Scripts in FMGo
          Mike_Mitchell

          Uncheck the "Show in Menu" checkbox in the Script Workspace.

           

          checkbox.png

          • 2. Re: How To Hide Scripts in FMGo
            beverly

            I believe eqitec says they are all unchecked.

            beverly

            • 3. Re: How To Hide Scripts in FMGo
              Mike_Mitchell

              Unchecked where? I don't see the scripts when I uncheck the "Show in Menu" box, as shown above.

              • 4. Re: How To Hide Scripts in FMGo
                Mike_Mitchell

                In fact, if no scripts are set to "Show in Menu", the Scripts menu is ghosted.IMG_0858.PNG

                • 5. Re: How To Hide Scripts in FMGo
                  steveromig

                  How can scripts be hidden from a guest user's view in the script listing in a FMGo14 App? I already have them unchecked in the Admin master app, and they are not supposed to be accessible in the guest user privileges. Yet, they are showing under FMGo when the user logs in as guest and, worse yet, when they click on one of the scripts, they get a dead end error message saying that they don't have access privileges to run the script. But there's no way out of the error message, so the app is essential unusable after that point. What am I missing. Thanks.

                   

                  I would double check that you are indeed unchecking the scripts you want to hide as Mike suggested.  Any settings like this that you do on the Desktop will carry over to FileMaker Go as well.  I have never seen it not work and if it isn't working then that might indicate a more serious issue going on.

                   

                  Steve Romig

                  FileMaker, Inc.

                  • 6. Re: How To Hide Scripts in FMGo
                    beverly

                    so if they are ALL unchecked, you see them anyway in FMGo?

                    Thanks,

                    beverly

                    • 7. Re: How To Hide Scripts in FMGo
                      eqitec

                      Yes, every script is unchecked in the FM13 master file, BUT the little box at the bottom of the scripts listing refuses to be unchecked. I uncheck it, then close out of manage scripts, and when I go back to manage scripts, it's checked again. Plus, I see now that the scripts are not hidden in the FM13 master file, so I guess it should be no surprise that they are visible in the FMGo file after the master has been moved to my iPad.

                       

                      Is there a setting in FM13 Security that is not letting me keep that one box at the bottom unchecked in the master file before it is move to the iPad? And should it matter anyhow since every script is unchecked in the master?

                       

                      Thanks all for your inputs.

                      • 8. Re: How To Hide Scripts in FMGo
                        Steve Wright

                        Whilst not an answer to the issue you are seeing....the checkbox at the bottom "Include in menu" is a default for new scripts being created or a way to bulk change a selection of scripts at once (when multiple are highlighted)

                        This being checked should have no effect on existing scripts that are unchecked.

                         

                        Im guessing here, having never seen the behaviour you describe, but:

                         

                        Are you really sure all scripts in all folders are unchecked.  i.e you have relevant privileges for all scripts and Show All is selected at the top of that window?

                         

                        Can you reproduce the behaviour in a new empty file?

                        • 9. Re: How To Hide Scripts in FMGo
                          eqitec

                          There are 9 DBs in my app, all of which have scripts, all of which are unchecked via Manage Scripts. Four of the ten DBs behave correctly, meaning that when launched under FMGo on my iPad, the scripts are not visible either from the drop down or the Manage Scripts, which is total greyed out.

                          I am trying to figure out why those 4 behave properly and the other 6 don't. All of the securities and privileges are set the same for all of the 9 DBs.

                          Haven't succeeded yet, but I have to keep trying.

                          Thanks.

                          • 10. Re: How To Hide Scripts in FMGo
                            beverly

                            I wonder if a bogus script (that does exit script only) and checked would help?

                             

                            beverly

                            • 11. Re: How To Hide Scripts in FMGo
                              eqitec

                              Is this a clue?

                               

                              There are 9 DBs in the FMGo App. The DBs which open normally on the iPad under FM14Go, normally meaning the scripts listing is hidden from the user, always starts with the request for credentials when I open them individually. When selecting "guest", the DB opens as it should with no scripts visible. In actual usage mode. the master DB opens them hidden, and they are never visible to the user.

                               

                              This doesn't happen with the DBs that are misbehaving, i.e., meaning they show the scripts listing to the user. When opening those DBs individually, they open right up without requesting credentials.

                               

                              It seems to me they should behave the same since the securities and privileges are set up exactly the same between the DBs which hide the scripts vs. those which don't.

                               

                              This strikes me as an important clue to my mystery, but I don't know what to make of it.

                               

                              Any further suggestions would be appreciated.

                              • 12. Re: How To Hide Scripts in FMGo
                                Mike_Mitchell

                                Any Custom Menus in use?

                                • 13. Re: How To Hide Scripts in FMGo
                                  beverly

                                  That was my next question!

                                  beverly

                                  • 14. Re: How To Hide Scripts in FMGo
                                    Mike_Mitchell

                                    GMTA ...  

                                    1 2 Previous Next