1 2 Previous Next 16 Replies Latest reply on Feb 9, 2016 10:11 PM by CarstenLevin

    Back up emails not always working

    nutsonshells

      Hi There,

       

      I am suddenly experiencing problems with the back up emails from the server. They used to come through every day for each hourly backup, but suddenly I am getting them on some days and not on others. Checking the log it shows, that the back up was completed, but there is no email to confirm.

       

      Anybody got an idea what the problem could be here?

       

      Thanks

       

      Kind regards


      Regine

        • 1. Re: Back up emails not always working
          CarstenLevin

          Hi Regine,

           

          My first question is about the SMTP server you are using. Is it reliable.

          The account you are using to send with, is it only used for this purpose and thus only for one user?

           

          There could be other reasons, but I would like to start here.

           

          Best regards

           

          Carsten

           

          Ps. version of FileMaker Server, Operating System ... and maybe a screendump of your setup of smtp on the server.

          • 2. Re: Back up emails not always working
            nutsonshells

            Hi Carsten,

             

            Thanks for your reply.

             

            I would assume the SMTP service is reliable, it is our internet provider. Here a screen shot of our settings.FMS 14 SMTP Settings.PNG

             

            The email info@ is a generic email account, that is widely used in our company. I could change it to my own or a different generic account.

             

            We are on Filemaker Server Version 14.0.4.413 on Windows Server 2012 R2 Standard.

             

            Thanks for assisting.


            Kind regards


            Regine

            • 3. Re: Back up emails not always working
              arehkopf

              Is your internet-connection reconnecting once a day?

              Maybe at the time the email should be send?

               

              Andreas

              • 4. Re: Back up emails not always working
                nutsonshells

                Hi Andreas,


                Thanks for your suggestion.

                 

                I am doing hourly back ups and should get 9 emails a day. So that can't be the problem, or should only affect one email per day.

                 

                Thanks


                Kind regards


                Regine

                • 5. Re: Back up emails not always working
                  CarlSchwarz

                  Is there anything in the Filemaker Server logs at that time?

                  • 6. Re: Back up emails not always working
                    CarstenLevin

                    Hi Regine,

                     

                    You are using your company's info account. I can also see that you are not using login.

                     

                    I am not saying that it is these issues that are causing the problem, just that maybe ...

                    • More than one connecting at the same time (reject from the smtp server).
                    • Security settings of the SMTP server limiting what can be sent without password.

                     

                    One way to test: Set up a dedicated mail account, best with login/password and test using only this.

                    Try also from a server script on the same server with the same credentials. A new filemaker file, a few fields and send mail via smtp script step.

                     

                    Best regards

                     

                    Carsten

                    • 7. Re: Back up emails not always working
                      CarstenLevin

                      Yes: As Carl write, do check the log history. Especially when the mails where going to be sent.

                      • 8. Re: Back up emails not always working
                        nutsonshells

                        Hi Carl and Carsten,

                         

                        Thanks for your suggestions.

                         

                        The email address is actually not doing anything. It is simply showing a From address in the emails received. I tested it with various emails addresses with different domains and it didn't make a difference, all tests came through.

                        I also tested it with login credentials, but it doesn't work at all, it only works with no credentials.

                        iinet is a pretty big company in Australia and their settings are standard and widely used.

                         

                        I checked both the FileMaker Server logs and the Server logs, but both don't show any email events or errors at the time of when the emails should have been sent.

                         

                        Just to be clear:

                        Emails were working fine including Tuesday, 02.02.16 (9 per day)

                        On Wednesday, 3.2.16 I only got the last three emails

                        On Thursday, 4.2.16 I got all 9

                        On Friday, 5.2.16 I got none

                        On Saturday, 6.2.16 I got none

                        On Sunday, 7.2.16 I got all 9

                        On Monday, 8.2.16 I got all 9

                         

                        So it is still a mystery.

                         

                        Thanks


                        Kind regards


                        Regine

                        • 9. Re: Back up emails not always working
                          CarlSchwarz

                          9 emails all in one hit is enough to trigger spam protection.  Do you use 3rd party spam protection?  Also try checking your Spam folder.  It's worth looking into that.

                          • 10. Re: Back up emails not always working
                            nutsonshells

                            Hi Carl,

                             

                            I am not getting 9 emails at the same time. I am doing hourly backups and should get one email per hour for a period of 9 hours.

                             

                            I have got a rule in my Outlook that automatically sorts all FileMaker Server emails into a specific folder. So no, not in spam either.

                             

                            Thanks

                             

                            Regine

                            • 11. Re: Back up emails not always working
                              CarstenLevin

                              Hi Regine,

                               

                              It is always difficult when working with one or as in this case two "dark holes". The FMS 14 and the SMTP server both running without an interface when sending/redirecting the mails.

                               

                              We have had many situations in the past, the same situation when a server script are sending an email ... it is happening from the same place/condition.

                               

                              In most cases we finally found the error in the SMTP setup, the rules of the SMTP server ... and while it could be different in your case I feel that this is the direction you should turn.

                               

                              But it could, I am just saying could, of course be a problem with your FileMaker Server. If you end up being very sure that all your settings are OK and that there are no external/SMTP issues you could consider reporting it as a bug to FileMaker ... here assuming that it is the FileMaker server that simply forget to send the email ... but I must admit, this I have not seen happen.

                               

                              Best regards

                               

                              Carsten

                              • 12. Re: Back up emails not always working
                                nutsonshells

                                Hi Carsten,

                                 

                                Thanks for your response.

                                 

                                At the moment it works fine and every emails is coming in as expected. I might give the internet company a call when the emails fail to come in next time to see, if there is an issue on their end.

                                 

                                I submitted a bug report and suggested to add outgoing email activity in the FileMaker Server log. Maybe they can implement that. It would definitely help.

                                 

                                For the moment I think I will just monitor it.

                                 

                                Thanks for your suggestions.

                                 

                                Kind regards


                                Regine

                                • 13. Re: Back up emails not always working
                                  CarlSchwarz

                                  If you start looking for more options then you can set-up webmail like outlook.com and authenticate with that.  It can be a pain to set-up and get working so I don't suggest rushing into that light-heartedly.

                                  • 14. Re: Back up emails not always working
                                    nutsonshells

                                    After not receiving emails again today, I have changed the SMTP to a different company and sure enough I got my backup emails again!

                                     

                                    I would have never thought that our internet company doesn't provide a reliable SMTP service, but at the moment I need to assume this was the problem.

                                     

                                    I will keep an eye on it and report back.


                                    Thanks

                                    Regine

                                    1 2 Previous Next