12 Replies Latest reply on Feb 9, 2016 7:58 AM by laura.bowyer

    Assistance with MonkeyBread CURL script please

    laura.bowyer

      Greetings!

       

      I need to be able to create a new issue in Jira from FileMaker 12 and then add an attachment (issue must be created first). I am using the MonkeyBread plug-in and trying to add the attachment, but not having any luck. I'm afraid I don't know or understand CURL so I'm driving blind here. If anyone can assist I would be ever so grateful!

       

      Here's what I have for the add attachment portion

       

       

      But here is the result I get:

       

      Hostname was NOT found in DNS cache

        Trying 10.1.2.124...

      Connected to jiradev.wz.hasbro.com (10.1.2.124) port 80 (#0)

      Server auth using Basic with user '_fmproserviceacct'

      PUT /rest/api/2/issue/MTGDRK-5010/attachments/lifepreserver.jpg HTTP/1.1

      Authorization: Basic X2ZtcHJvc2VydmljZWFjY3Q6TUBkM1doMGwzIQ==

      Host: jiradev.wz.hasbro.com

      Accept: */*

      Transfer-Encoding: chunked

      X-Atlassian-Token: no-check

      Expect: 100-continue

       

      HTTP/1.1 100 Continue

      HTTP/1.1 404 Not Found

      Server: Apache-Coyote/1.1

      X-AREQUESTID: 851x45906x1

      X-ASEN: SEN-4401886

      Set-Cookie: JSESSIONID=E56B86AEE8DED954CD714FFE93CDC950; Path=/; HttpOnly

      X-Seraph-LoginReason: OK

      Set-Cookie: atlassian.xsrf.token=BLTB-16HX-FS1D-A6XF|771ba708aa6b8934ae81f7c6bd433714b6e38e22|lin; Path=/

      X-ASESSIONID: ozfd1s

      X-AUSERNAME: _FMProServiceAcct

      Cache-Control: no-transform

      X-Content-Type-Options: nosniff

      Vary: Accept

      Content-Type: application/xml;charset=UTF-8

      Content-Length: 222

      Date: Mon, 08 Feb 2016 22:11:31 GMT

      Connection: close

       

      Closing connection 0

       

       

      The overall result is OK, which appears to tell me it was successful, but the attachment doesn't appear.

       

      Thanks in advance for any assistance!

      Laura