4 Replies Latest reply on May 20, 2017 12:33 AM by roel

    Comma decimal point problem

    pedroble

      I have a Spanish Windows in my machine. It's really no problem and I have got used to the comma marking the decimal and a dot marking the thousands.

      I press the dot key for my decimal and I get a comma in Excel but it still counts as a decimal point

      My problem comes with Filemaker - it will not accept the dot key to mark the decimal and I am obliged to use the comma.

       

      Is there any way to reset Filemaker?

        • 1. Re: Comma decimal point problem
          pedroble

          The only references I have found to this sort of problem are ...

          comma as decimal point - confusion

          Re: Comma as decimal, Mac keyboard

          Re: Number format/display query.

          ... none of which answer the question.

           

          For me it is not important whether commas or dots are used.

          What is important is to be able to to use the numeric keypad to write the decimal point instead of being obliged to use the ','.

          • 2. Re: Comma decimal point problem
            user19752

            I guess you don't need to enter dot for thousand, then use auto-enter calculation (replace existing value) for the number field

            Substitute ( Self ; "." ; "," )

            will replace all dot entered from num pad to comma then used as decimal point.

            • 3. Re: Comma decimal point problem
              pedroble

              Thank you user19752.

               

              That seems to work very well using "." for the thousands separation > 1.000.000,00

              • 4. Re: Comma decimal point problem
                roel

                I had the same problem (on Windows, Dutch number format (i.e. comma as decimal symbol), working with keypad with International Keyboard Layout). When entering € 123,45 (one hundred and twenty-three euros and forty-five cents), Filemaker registered € 12.345,- (twelve thousand three hundred and forty-five euro).

                 

                The provided solution does its trick. When I enter a decimal via the keypad, Filemaker registers a 'period', that is substituted by a 'comma'. In other words, when entering € 123,45 Filemaker converts it to € 123.45 and stores it in the database. By configuring the Data Formatting-settings of this specific field, Filemaker displays the value as "€ 123,45".

                 

                My question is: Is this really the only solution to this problem?? It implies that I have to remember to use ' Auto-enter calculation' for EACH number field in my database.

                 

                The strangest thing is, that only Filemaker acts in this way. For example Excel correctly 'sees' the decimal-button on my keypad as a comma (since that is the Region settings of my operating system).