2 Replies Latest reply on Feb 10, 2016 1:13 PM by Smef

    Step into in debugger pegs server CPU

    Smef

      Hello,

       

      I've found an issue where the "step into" button to step into a script causes FileMaker Server's CPU usage to max out for 10-20 seconds while the step-into is running until the step into is complete and the "stepped-into" script is displayed with the debugger on the first step of the stepped-into script. Once the step into completes the CPU usage drops back down to normal levels. While this is happening FileMaker becomes unresponsive.

       

      Product and version FileMaker Server 14.0.4.413 and FileMaker Pro Advanced 14.0.4

      OS and version - Server is on Win 2012 R2 and Pro Advanced is Mac OS 10.11.3

      Browser and version (for WebDirect only)

      Hardware - Server is AWS virtual machine, Pro is on a 2013 iMac

      Description

      How to replicate - It's not reliably triggered, but using the "step-into" button can cause FMP to become unresponsive and the server CPU to max out until the step-into is able to resolve and show the script being stepped into

      Workaround (if any) - none, but running the script is fine - it's only when running the debugger and stepping into the script that the problem shows up

        • 1. Re: Step into in debugger pegs server CPU
          TSGal

          Smef:

           

          Thank you for your post.

           

          From your description, it is difficult to determine the cause.

           

          Have you tried using FileMaker Pro to access a hosted file on a non-virtual server?  If so, do you still have the same issue?

           

          Have you tried a different copy of FileMaker Pro?

           

          What other actions are being performed on the virtual server when you encounter the delay?

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Step into in debugger pegs server CPU
            Smef

            I'm sorry that it's such a broad bug report. I'll do my best to get more details for you, but while I've seen this frequently, it seems random for when it will be an issue. The strangest part is the high CPU usage on the server while the wait is happening. The CPU is totally maxed out while FMP is waiting, and just running the script doesn't bring up these issues.


            I've seen this from many different FMPA clients on different connecting to different remote servers, virtual or physical.

             

            I've seen this issue when there is no activity on the server (no scripts being run, backups, etc) and I'm the only connected user. FMS is the only thing installed on these machines as well, so there isn't another application taking up this CPU time. In addition, it's clear from the activity monitor that FMS is what is maxing out the CPU.


            One the step-into is complete the CPU usage returns to normal, minimal levels.