1 2 3 Previous Next 38 Replies Latest reply on Feb 15, 2016 11:21 AM by Mike_K

    "New Record" button is overwriting Existing Records - Solution?

    Mike_K

      I'm a self-taught user of Filemaker, and I can't figure out this problem for the life of me.  Any help is immensely appreciated!

       

      (Please note the database I'm using is built from a starter solution.  I can't remember the actual name of the starter solution, but it provides tabs at the top of the screen for "Dashboard", "Invoices", "Customers", and "Products".  There might be others, but those for sure.)

       

      In a Nutshell:

       

      In my Table named "Products",

      I click the "New Record" button in the main menu bar while on my "Products" layout.

      Filemaker does NOT create a new record as promised - it instead overwrites an existing record (the lowest numbered key field - "Product ID") with the next auto-serialized number.

       

      I have "Product ID"s starting at 71 and ending at 253, with the lowest number being overwritten by the "New Record" command.

      Thus, my next new product entry will overwrite record 71, auto-serialize it to be 254, and i'll end up with the same total number of records starting with 72 and ending with 254.

       

      Deleting Records works as expected.  (unfortunately...  I was hoping it would magically restore deleted records in similar fashion as the new record button magically overwriting records, but alas, it does not.)

       

      I run this database on a mac (Host) that I remotely connect to using 2 other macs (users).

      All changes to the database (program and data entry) are done with a user mac over the LAN using "open Remote".

      I have tried "New Record" on the Host mac, and the problem persists... it is quite stubborn.

       

      A few more notable items:

       

      Nowhere else in this entire database does this problem exist, and it has evolved to include a lot more tables (not just occurrences).

      I estimate this problem started when I relocated the database to what is now the Host mac, from the now User mac that I use most.

      Before I moved the database over to the now Host, everything worked perfectly as I was able to populate the table from record "0" and up.

      I did not become aware there was a problem until today, when some commonly used Product records were not to be found.

      Upon some testing, I noted that the number of records overwritten (70), is estimated at about the number of records I would have attempted to add since porting everything over to the now Host.

      Another thing worthy of mention is that I thought I solved the problem when I noticed the "Product ID" key field was set to "Text" instead of "Number".  When I sorted this field in ascending order, it placed the order from 100 to 253, and then from 71 to 99.  I changed it to "Number", but I still have the same problem even though everything sorts better.

       

      I'm pulling my hair out with this.

      Please Help!!!!

        1 2 3 Previous Next