1 2 Previous Next 19 Replies Latest reply on Feb 15, 2016 1:11 PM by CarstenLevin

    Can't Open FMP

    lynnelemoine2

      I am new here - first day.  I have someone creating a database for my church cemetery which I am the administrator for.  I purchased FMP14 last year and we gone through about 3 revisions. It is about where I want it to be and planned on spending the weekend entering data.  I entered a little during the week and had no problems.  Yesterday I could not open FMP and/or the database.  When opening FMP I see nothing and if I go to the database I get the window up for the password but once the password is entered and I click OK it disappears as it should but the database does not open.

       

      The last version of FMP I used was 5 - he originally created a database for the cemetery in the early 2000s.  I had no need to do anything else in FMP 14 so the only thing saved in FMP is the database - 3 different versions.

       

      I uninstalled FMP and reinstalled it and that did not solve the problem.  The person doing my database uses MAC (which I wish I did) but I'm on an HP with Windows 8.1 at both the church/cemetery and at home.  I am having no problems with Word, Excel, Publisher or getting on line.

       

      If anyone has any suggestions I would appreciate it very much

        • 1. Re: Can't Open FMP
          user19752

          What do you see in "Window" menu when "it disappears"? Is there window name in last menu item?

          If there is, try

          Window > Cascade Windows

          menu.

          • 2. Re: Can't Open FMP
            lynnelemoine2

            Once the window asking for password closes I'm back to the desktop so there is nothing to see that I am aware of.  If the program opened I might be able to see last opened but it doesn't open. 

            • 3. Re: Can't Open FMP
              user19752

              So it looks like there is a script that "Quit application" and set it as "onFirstWindowOpen" trigger script...

               

              Have you tried to recover the file?

              Make a copy of the file

              Run FM

              File > Recover... then open the copied file.

              • 4. Re: Can't Open FMP
                mark_baum

                I'm moving this thread to the Discussions area where it may get more attention. Cheers -- Mark

                • 5. Re: Can't Open FMP
                  CarstenLevin

                  So it looks like there is a script that "Quit application" and set it as "onFirstWindowOpen" trigger script...

                   

                  Have you tried to recover the file?

                  Make a copy of the file

                  Run FM

                  File > Recover... then open the copied file.

                   

                  There is no logic in using the recover function if the file does not appear to be damaged. Suggestion: A more systematic approach to this problem.

                  • 6. Re: Can't Open FMP
                    CarstenLevin

                    Dear Lynne,

                    Establishing some facts:

                    • The database is made for/has been up and running in FileMaker 14?
                    • You where entering data this weekend without any problems?
                    • No changes done from when you could use the database and until now when you can not?

                     

                    Questions:

                    • Is your database solution stored locally or do you access it on a server?
                    • Can you ask your developer ... did he do any changes ... does he have FileMaker Pro Advanced 14, and if so, can he open with debugger active and see what is happening.

                     

                    Best regards

                     

                    Carsten

                    • 7. Re: Can't Open FMP
                      user19752

                      There is some probability that opening damaged file crashes FM then silently close.

                      Recovering file is only way to determin the file is damaged or not, isn't it?

                      • 8. Re: Can't Open FMP
                        Tom_Droz

                        I have had this happen, it is running but it has been set to "minimize"  This is a FM problem but can be fixed easily.

                         

                        I assume you are on windows, open the task manager, click on FileMaker then select maximize

                         

                        tom

                         

                        • 9. Re: Can't Open FMP
                          CarstenLevin

                          If the file is being accessed from a fms server 14 it is probably not damaged, probably. That is why I am asking the questions you can see here. We need to know more before giving specific advice.

                          • 10. Re: Can't Open FMP
                            lynnelemoine2

                            Thank you.  I wasn't sure where to go.

                            • 11. Re: Can't Open FMP
                              lynnelemoine2

                              Yes I was working on it on Thursday and Friday evenings and when I went to get into it on Saturday I could not open FMP.  The database itself is fine I put it on a USB drive and brought to the church and it opens fine in FMP here. 

                               

                              Sunday I did the uninstall and reinstall thinking something happened a part of the software wasn't working but it still isn't opening.  It doesn't open whether I click on the FMP desktop icon or go to where it is saved.  If I attempt to open the database I get the window asking for the password but the program isn't opened. 

                               

                              The guy who is doing the database set up for me is a MAC guy and doesn't know Windows.  He has made no changes to it since I entered data in on Thursday.  I even went back to the copy he emailed me in case it was something with the database I did after I got it but that doesn't open FMP either.

                               

                              The end result will be that the database will sit on the church computer and I'll access it from there.  I know we will be moving the office in mid-May to early June and was hoping to wait until then to set it up but if it works here I may have to do it sooner.  Right now we have U-verse it isn't reliable in our area.  I also have the computer set up to connect with another so I have to figure out how to let me connect to here. 

                               

                              I appreciate any ideas.

                              • 12. Re: Can't Open FMP
                                lynnelemoine2

                                Yes I am on Windows 8.1 at both home and church/cemetery.  I copied the database this morning to a USB drive and it is working fine at the church. 

                                 

                                Thanks for the suggestion I will try it this afternoon as soon as I get home.

                                • 13. Re: Can't Open FMP
                                  lynnelemoine2

                                  I don't have anything set up as a server as of right now.  I had planned on doing the majority of the data entry at home and then bring to the church.  I work part time and run both the church and cemetery so not a lot of time for entering the information here.  The church/cemetery computer will be the one to become the server for the database so I can access from anywhere but was hoping to do that after the office moves and I get with a more reliable internet provider like Cox - Uverse is not reliable in our area and I have to reconnect numerous times a day.  There is more to do to the database such as connecting forms to attach to each record and probably once we get to that point I will need it sitting here at the church because the forms will be used here when people come in. 

                                   

                                  I will try the other suggestion to check task manager to see if it was minimize - if it is I can't see anything showing on the desktop. Firefox does that occasionally but I see a small box in the top left hand area.

                                  • 14. Re: Can't Open FMP
                                    Tom_Droz

                                    I can almost guarantee you that is what is happening

                                    1 2 Previous Next