AnsweredAssumed Answered

Corruption "invalid table key"

Question asked by quirkycrone on Feb 15, 2016
Latest reply on Feb 16, 2016 by quirkycrone

Have gone round and round on this one.  FM 13, advanced. Running X-platform.

 

I noticed the problem when I could not FIND a record having an alpha/numeric field (in the form "A999". Someone in the Community helped me modify my search string to include a lead asterisk, and that worked okay to accomplish the data update I was attempting. But the "relationship" still appeared to be not working. So I Split up the search field into 2 fields, one for the alpha and another for the numeric portion in both of the tables I was relating and established the relationship by matching the partial fields.  That worked also.

 

But the larger ISSUE that developed was that in the process of doing this I began running Recover on my Databases, or at least the two that run in my application. Both Databases say that I should not use the database going forward. Both passed the consistency check. Both show the same errors in the Recovery log. "Invalid table key" subsequent to Contact.Last  (name). Searching for a database that does NOT show this error seems futile (I have run recover on databases sin August 2015, they all report the same error while finding and displaying contact names without any apparent problem -- the "WHO KNEW? issue.)

 

In an attempt to see if I could create a "clean" database, I have followed all the suggestions in the Tech Brief on Recovery to no avail. Clones, compacting, deleting and bringing back data from Merge files. All the results show the same error in the same place. Except for exporting the file to a separate database.  Then Contacts check out fine, but when I attach the file from the external database, replacing the one which appears (according to Recover) to contain the "Invalid table key", I still have the samo samo Recover error.

 

I tried deleting the field LAST also, but it seems irrevocably interfaced with other calculation fields.

 

Suggestions?  I really don't want to rebuild from scratch. PLEASE DON't YELL AT ME About Clean Backups. I guess I should have read the Tech Briefs FIRST.  But what's done is done until I can get a clean database.

 

BTW when I remove the file Contacts from the database ENTIRELY (Contacts, Contacts 2, etc)...Recover still shows the same problem...

 

Thanks for your attention.

Outcomes