3 Replies Latest reply on Feb 16, 2016 12:55 PM by macwombat

    Missing Pasted Field Names

    AngelArs

      I'm fairly new to FM so the answer to this question is probably fairly easy.


      I started a new solution. The end product needs to look like an excel sheet (table). Since all of my tables will have the same names for their field names, I copied my first tables field names and pasted them into all the other tables. When I go to Manage > Databases everything looks correct.


      However when I'm in Browse mode and I select the different tables from the layout drop down menu, only my first table shows the field names, all of the other tables (that I pasted the field names into) do not show any field names. What am I doing wrong?

        • 1. Re: Missing Pasted Field Names
          macwombat

          Hi.  Welcome to FM

          Did you copy the fields from your first layout onto the other layouts?  If so, when you are on layout B (based on table B) then your  fields will be from table A.  You need to check that the fields on each layout are the fields from the table that the layout it based on, or that they are from a table that is related.

          HTH.  Chris

          • 2. Re: Missing Pasted Field Names
            AngelArs

            Chris Cullen wrote:

            Did you copy the fields from your first layout onto the other layouts?

            No, I was in browse mode, not layout mode. I copied the field names when I was importing the tables. I haven't been in layout yet, not even for the first table. I originally imported the tables as excel files, but they said "f1", "f2", f3" ect. So I renamed the first tables field names and then (while in Manage Database) I copied the field names from the first table, and pasted them into all the other tables.


            Should I have copied all the field names while in layout mode, instead of browse/manage database mode?

            • 3. Re: Missing Pasted Field Names
              macwombat

              Each layout that is not displaying what you expected - go into layout mode and see what is there.  It may be that they are blank layouts and that you need to put fields and field names (text boxes) on those layouts.