1 Reply Latest reply on Feb 16, 2016 1:52 PM by TSGal

    Field Sort Order Changes after Editing Attributes in the Manage Fields Dialog

    Malcolm

      Product and version

      FileMaker Pro 14.0.4

       

      OS and version

      Mac OS X 10.10.5


      Hardware

      MacBook Pro (Retina, 15-inch, Mid 2015)

       

      Description

       

      After editing a field definition it is moved to a different position in the list

       

      How to replicate

      I have the file open locally - I have not seen this when the file is open on the server.

       

      I have the manage field dialog open and sorted by TYPE.

       

      I am modifying the auto-enter calculation.

       

      When the changes are complete and I close all the dialog windows the field moves to a different position in the list.

       

      If the selected field was at position number four in a list of ten, after the field moves, the selected item is still at position number four. In other words a different field is selected.

       

      In addition, a dialog box will appear asking if I want to save changes to the field which is now the selected item in the list.


      Workaround

      I have not looked for a workaround

        • 1. Re: Field Sort Order Changes after Editing Attributes in the Manage Fields Dialog
          TSGal

          Malcolm:

           

          Thank you for your post.

           

          I am unable to replicate the issue.  This is what I have done:

           

          1. Using FileMaker Pro 14.0.4 under Mac OS X 10.10.5 (and also under Mac OS X 10.11.3), I created a database file with 10 fields as follows:

          F1 (Text)

          F2 (Number)

          F3 (Text)

          F4 (Number)

          F5 (Text)

          F6 (Number)

          F7 (Text)

          F8 (Number)

          F9 (Text)

          F10 (Number)

           

          2. I sorted by Type, and the Text fields appear above the Number fields.

           

          3. I select field F7, which happens to be fourth in the list, click on "Options...", go to the Auto-Enter tab, click on "Calculated value", enter the formula:    Lower (F7)

          ... click OK to close Specify Calculation, click OK to close Options for Field "F7", and field F7 is still highlighted in the fourth position.

           

          Let me know what I'm doing differently than you so I can replicate the issue.

           

          TSGal

          FileMaker, Inc.