3 Replies Latest reply on Feb 18, 2016 3:41 AM by disabled_morkus

    JDBC Issue - 501 Runtime error (Field failed time value validation test) on Import  (***Resolved***)

      Hi all,

       

      I was doing a rather simple import of some data to FMP 14 via JDBC when after three successful records imported, I got this error:

       

      com.filemaker.jdbc.FMSQLException: [FileMaker][FileMaker JDBC]  (501): Field failed time value validation test

       

      ----------------------------------


      SOLVED IT!


      For some reason, the JDBC "ALTER TABLE ADD [COLUMN NAME] [FIELD_TYPE]* DDL that I used to create the field marked that field as *always validate.*

       

      The first three records had null for the single Timestamp field but the fourth record, which was the cause, had this: 11/01/1990 0:00:00.

       

      It doesn't seem that FileMaker liked the zero time portion - at least not with that validation option.

       

      SOLUTION: I turned off the validation options for that field in FM's field options so it was the default:

       

      Import worked fine for all 20,000 records after that.

       

      - m