3 Replies Latest reply on Feb 17, 2016 4:14 PM by beverly

    ALTER TABLE for TimeStamp turns on Validation causing import failure

      Creating a TimeStamp field via JDBC and ALTER TABLE ADD Column syntax seems to force the "Always Validate" to be ON.

       

      This setting causes lots of problems since FileMaker doesn't seem to like some of the TimeStamp values brought in from the "other" database. All zeros for the time seems to be problematic, for example.

       

      The FileMaker SQL Reference Manual states:

       

      Make sure Strict data type: 4-Digit Year Date is not selected as a validation option in the

      FileMaker database file for a field using this 2-digit year syntax.

      Note The 2-digit year syntax is not supported for the ODBC/JDBC format or the SQL-92

      format.


      -----


      Yet, I can't find a way, via the DDL over JDBC (an alternative ALTER TABLE syntax, that is) to create a TimeStamp field without the Always Validate option ON.

       

      Once I manually change the field definition in FileMaker, and restart the code, the import succeeds.

       

      The goal is to create the fields and import all in one batch.

       

      Appreciate in advance any suggestions,

       

      Thanks,

       

      - m