8 Replies Latest reply on Feb 22, 2016 2:46 PM by TSGal

    JDBC "CREATE TABLE" OR "ALTER TABLE" HAS VALIDATION TO "ALWAYS VALIDATE" FOR TIMESTAMP/NUMERIC FIELDS

      When doing DDL commands to create a table (or ALTER TABLE for a TimeStamp field, FileMaker's JDBC driver creates the TimeStamp field, but FORCES the "Always Validate" ON for TimeStamp (and NUMERIC) fields.  FileMaker also forces "Always Validate" for numeric fields, but these seem to be less problematic:

       

      Below is an example of how FileMaker sets the validation after it sets a TimeStamp field via CREATE or ALTER TABLE over JDBC:

      This forced validation causes many imports to crash even though the TimeStamps are in the right format (NOTE: FileMaker doesn't use standard date formats (as in, for example, 2015-03-06 12:51:08) so extra work is needed to convert those to FileMaker-specific format first.

       

      An example of a date I imported from another database platform and converted for FM is: 11/19/2014 10:55:35

       

      -------------------

       

      ISO 8601 - Wikipedia, the free encyclopedia

       

      -------------------

       

      Here is a small subset of the fields FileMaker forced to "Always Validate". For Timestamp fields, I need to manually change each one via the FMP interface. A couple tables I import have nearly 200 fiels each.

       

       

      -------------

       

      While what I'm reporting here may not be a bug per se, my basic question issue is: Is there any way to control how FMP sets the "Always Validate" option when doing a CREATE OR AN ALTER TABLE DDL command via JDBC? Perhaps an argument to the DDL for a particular field like "NO VALIDATE" or something like that?

       

      I could not find any "Validate" references in either of the two FM Reference Manuals:

       

      1. SQL Reference, or

      2. ODBC/JDBC Reference

       

      Look forward to hearing back with any suggestions or workarounds (other than manually having to change 20 or 30 fields every time I do a CREATE OR ALTER table.)

       

      Thanks,

       

      - m