8 Replies Latest reply on Aug 4, 2017 11:05 AM by realgrouchy

    Autofill in calculation editor doesn't work after a ≠ sign

    realgrouchy

      This is a nuisance that I've been meaning to report:

       

      In FMPA 14 on a mac, when editing a calculation e.g. in the Script Workspace.

       

      Enter a calculation area (such as the value calculation of a variable), and type "Fieldname ≠ Fie" (where "Fie" is the beginning of a valid fieldname or expression in the database).

       

      Expected behaviour: Autocomplete suggests "Fieldname"

       

      Actual behaviour: No suggestion

       

      Workaround: Backspace to the ≠ sign and type the space again.

       

      I can't reproduce this on FMPA Windows 14.0.4, but I'm not sure how to get the ≠ sign; I'm pasting it.

       

      - RG>

        • 1. Re: Autofill in calculation editor doesn't work after a ≠ sign
          TSGal

          realgrouchy:

           

          Thank you for your post.

           

          I am unable to replicate the issue using FileMaker Pro 14.0.4 under Mac OS X 10.11.3.  This is what I have done:

           

          1. I created a database file with 6 Text fields:

          Fieldname

          Field1

          Field2

          Field3

          Field4

          Field5

           

          2. I created a Calculation field "Calc".  In the formula section, I selected "Filename".  On the right side of the Calculation, where all the characters are located (" ", &, ¶, etc.), I clicked on the "≠" character, and then when I entered Fie, I see the entries for Field1, Field2, etc. along with functions FieldBounds, FieldComment, FieldIDs, etc.

           

          3. I created a script "TEST" with Set Variable.  In the calculation area, I entered "Fieldname", pressed the keyboard shortcut option-= to get ≠, and then when I typed "Fie", I saw the same options for Field1, Field2, Field3, etc.

           

          4. Under Windows 7, I created a similar file, and following step 2, I am able to click "≠", and enter "Fie" to display the same entries (Field1, Field2, etc.).

           

          Let me know if you are able to reproduce the issue without pasting the "≠" character.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Autofill in calculation editor doesn't work after a ≠ sign
            realgrouchy

            Sorry, I omitted a key detail:

             

            In OS X, I am typing option+= on the keyboard to produce the ≠ sign.

             

            - RG>

            • 3. Re: Autofill in calculation editor doesn't work after a ≠ sign
              realgrouchy

              It looks like this problem occurs with previous versions of OS X (Yosemite 10.10 and earlier), but not with El Capitan (10.11). I tried in both FMPA 15 and FMP 14.

               

              Unfortunately, I can't update my computer to El Capitan until an unrelated driver conflict is resolved.

               

              - RG>

              • 4. Re: Autofill in calculation editor doesn't work after a ≠ sign
                realgrouchy

                I'm re-raising this because I'm getting the problem in FMPA16 on MacOS Sierra (10.12.x), and I've reproduced the error on other OSX machines in our office.

                 

                Here are steps to reproduce:

                - Create a new database with a single field, called "notequals"

                - create a new script

                - Create an If statement in the script, and begin typing "notequals ≠ no..."

                (* use the Mac keycombo alt+= to get the ≠ sign)

                 

                Expected results:

                - When you type "no" the second time, it should suggest the field name "notequals"


                Actual results:

                - It does not recommend anything.

                 

                Notes:

                - This works for any suggestions, including functions, not just field/table names

                - In a test in another database, the problem behaviour did not show up when I tried creating an if statement "fieldname ≠ Substi...", but then when I opened the calculation editor and expanded this to "fieldname ≠ Substitute ( 1 ≠ fie... )" it did not recommend "fieldname" when I typed "fie".

                 

                Workaround:

                - After typing the ≠ symbol and a space, backspace to the ≠ symbol and enter a space again.

                 

                - RG>

                • 5. Re: Autofill in calculation editor doesn't work after a ≠ sign
                  TSGal

                  realgrouchy:

                   

                  I am unable to reproduce the issue.  This is what I have done with FileMaker Pro Advanced 16 under macOS Sierra 10.12.6:

                   

                  1. I created a new database file (1f.fmp12) with a Text field named "notequals".

                  2. In Script Workspace, I created a new script "New Script".

                  3. In the first line of the script, I entered "If", and for the calculation, I entered "notequals" followed by a space, followed by alt+=, followed by a space, and typed "no".  "notequals" immediately appears as a recommendation.

                   

                  4. I created a Calculation field "Calc" typing the same formula, and "notequals" appears as a recommendation before and after the "≠".

                   

                  At no point did I press the backspace key.

                   

                  Do you have any plug-ins enabled/installed?

                   

                  TSGal

                  FileMaker, Inc.

                  • 6. Re: Autofill in calculation editor doesn't work after a ≠ sign
                    realgrouchy

                    Hi TSGal,

                     

                    Sorry, I missed a detail.

                     

                    I created an If statement, and I began typing "not...". This brought up the field selector and I selected the field "Notequals test::notequals" and pressed Return.

                     

                    Screen Shot 2017-08-04 at 13.13.30.jpg

                     

                    Then I typed ≠ no... and it failed to give a suggestion.

                     

                    Screen Shot 2017-08-04 at 13.13.38.jpg

                     

                    So the If statement that I typed actually read "Notequals test::notequals ≠ no...", not "notequals ≠ no..." as I indicated in my previous message.

                     

                    I was able to reproduce this in both FMPA16 and FMPA15.

                     

                    I have no plugins installed.

                     

                    - RG>

                    • 7. Re: Autofill in calculation editor doesn't work after a ≠ sign
                      TSGal

                      realgrouchy:

                       

                      Using your sample file, I am still unable to replicate the issue using FileMaker Pro Advanced 16.0.2 under macOS Sierra 10.12.6, and FileMaker Pro Advanced 15.0.3 under Windows 7.

                       

                      Screen Shot 2017-08-04 at 10.25.00 AM.png

                       

                      Screen Shot 2017-08-04 at 10.25.27 AM.png

                       

                      Is there any other information you can provide about your computing environment that will help me reproduce the issue?

                       

                      TSGal

                      FileMaker, Inc.

                      • 8. Re: Autofill in calculation editor doesn't work after a ≠ sign
                        realgrouchy

                        Okay, I've narrowed down the problem to the alt key.

                         

                        It turns out that because I type quickly, the alt key is not fully released when I hit space. So instead of

                        alt+=
                        space

                         

                        I am pressing

                        alt+=+space

                         

                        Since the output in the Script Workspace comes out the same, I never noticed. It would be nice if the script workspace were to treat alt+space as space in this context for situations like this. (This problem only occurs with alt+space; shift+space seems to work properly, ctrl+space does not enter a space, and cmd+space is the keyboard shortcut for Spotlight)

                         

                        - RG>