10 Replies Latest reply on Feb 28, 2016 12:27 PM by iking42

    FMP 14.0.5 Crashes On Startup

    iking42

      I am running Windows 10 Pro 64 bit, 8 GB ram, Core 2 Duo, T8300@2.4 GHz

      Upgraded FMP 14 to 14.0.5 and functioned as expected.

      Changed preference memory setting from 128 to 256 and FMP crashed on startup.

      Cannot get to preferences to reset memory to 128 if that was the cause.

      Removed FMP from system using System Removal process

      Reinstalled FMP 14 and all upgrades to 14.0.5

      No change. Software still crashes on startup.

       

      FileMaker Pro Advanced has stopped working

      A problem caused the program to stop working correctly.

      Windows will close the program and notify you if a solution is

      available.   Options; Debug or Close program

       

      Any help would be appreciated. We are shut down and desperate!

        • 1. Re: FMP 14.0.5 Crashes On Startup
          Steve Wright

          You could try this.. obviously at your own risk....

           

          The cache setting is stored in the windows registry, it's under:

          HKEY_CURRENT_USER/Software/FileMaker/FileMaker Pro/14.0A/Preferences

           

          You should see Cache Size | REG_DWORD |  0x00040000  (for 256)

          Changing that value to 20000 will set it as 128 cache size (I just double checked)

           

          Or, completely uninstall it again... delete the preferences from the registry and try another clean install.

           

          Obviously, this doesn't answer why it's crashing.. but if changing the cache triggered it, maybe changing it back will get you up and running until you can get to the bottom of it.

          • 2. Re: FMP 14.0.5 Crashes On Startup
            iking42

            Thanks Steve. I have tried the reinstall three times to no avail. Applied the suggested Registry change. Did not solve problem. Have reinstalled FMP Advanced 13 and it functions as expected. However, FMP 14 Advanced still crashes on startup. I may have a corrupt reinstall package. Can you direct me to a valid download link for the basic FMP 14 Advanced package. Only path I can think of that is rational at this point.

            • 3. Re: FMP 14.0.5 Crashes On Startup
              Markus Schneider

              the original link for the download (if You purchased FM online) still works - and there are the latest full installers. If You don't have the original link, You can contact the FileMaker support - they will send You the link. There is no link to a full version in general, therefore, one has to contact FM support

              • 4. Re: FMP 14.0.5 Crashes On Startup
                iking42

                Thanks for the help. Found my original email and downloaded fresh copy of install file [fmpa_14.0.4.406_x64]. Removed existing install, restarted, installed using fresh install  file. Same results. Crashes on launch. Checked registry, preferences cash set at 128k so that should not be the problem. FMP 13 Advanced launches and runs with no problem. Going hairless at a rapid rate.

                • 5. Re: FMP 14.0.5 Crashes On Startup
                  iking42

                  One added bit. Fails just after opening the Launch Center window Displaying Favorites and Recent files. These appear to be complete and correct. As soon as the window fills, the error message appears.

                  • 6. Re: FMP 14.0.5 Crashes On Startup
                    schamblee

                    FMP 14 comes in 2 versions 32bit and 64bit for Windows, which version are you installing?   I suggest try installing the other version, note FMP13 only came in 32bit version.

                    • 7. Re: FMP 14.0.5 Crashes On Startup
                      Steve Wright

                      Try running "SFC /scannow" from command prompt (run as administrator) to see if that digs up any corrupt system files.

                      Some info on SFC:  https://support.microsoft.com/en-us/kb/929833

                       

                      Also, are plugins involved / auto-installed by the solution?  If so, have you tried removing them and opening a blank/new file?

                      • 8. Re: FMP 14.0.5 Crashes On Startup
                        iking42

                        Ran SFC, clean response. Removed 64 Bit and installed 32 Bit. Program runs as expected. Plugins were involved but I do not know how to disable or remove them when the software crashes before I can interact in any manner. Perhaps some registry key that would do the trick but I am not that clever. The 64 Bit version worked fine until upgrade 5. It appears that  the memory change did not cause the problem and the plugins were installed and functioning under upgrade 4. Had all the reported scripting problems which update 5 was supposed to fix. System went south within several launches after update 5.

                        • 9. Re: FMP 14.0.5 Crashes On Startup
                          Steve Wright

                          Just for future reference, plugins are normally installed into the Appdata folder on windows, you can get to the location for FileMaker Pro Advanced by pasting this into the address bar:

                           

                          %appdata%\..\Local\FileMaker\FileMaker Pro Advanced\14.0\Extensions

                           

                          Although that is only one of the possible locations, see here for all the details:

                          Installing and updating plug-ins in FileMaker Pro | FileMaker

                           

                          Each architecture version (32bit / 64bit) requires its own, compatible plugin files on Windows..  you can determine this by the file extension, either .fmx (32 bit) or .fmx64 (64bit) 

                           

                          If you experience issues in the future, you can try moving the plugins out of the folder(s) listed above to a temporary location.. and open a blank / new file to see if its plugin related or not.  It may well be.  Solutions can install plugins automatically (If setup to do so), hence the blank / new file.

                           

                          Nice to hear you are up and running again though

                          • 10. Re: FMP 14.0.5 Crashes On Startup
                            iking42

                            You are spot on, Found three Plug Ins in Extensions. Removed, reinstalled 64Bit version and problem cleared. Reinstalled update 5 and Solution still loads as expected. Research shows Solution is using the "Container" and "Script" process to install plug ins which I must have inadvertently activated. Back on line and looking intelligent. Thanks for the assist. May have saved my job :-)